Dell VNX: No se puede acceder a la interfaz web de la interfaz de usuario de Unisphere después de la actualización

Summary: Después de una actualización de código de OE, Unisphere se volvió inaccesible, el archivo httpd.conf volvió al valor predeterminado y, tras la edición, se ingresó un espacio adicional, lo que causó problemas con el script apache. (Corregible por el usuario) ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Actualizaciones de Flare OE y NAS.

No se puede acceder a la interfaz web de Unisphere después de una actualización de código NAS y OE Flare. Unisphere se volvió inaccesible, el archivo httpd.conf volvió a los valores predeterminados y, tras la edición, se ingresó un espacio adicional, lo que causó problemas con el script de Apache.

 

Cause

El cliente tuvo que volver a editar /nas/http/conf/httpd.conf después de una actualización, ya que el archivo vuelve a los ajustes predeterminados.
En este caso, el cliente tuvo que volver a agregar cifrados de seguridad en la línea SSLCipherSuite. Sin embargo, cualquier error en la edición, como dejar un espacio adicional en el archivo, puede hacer que el script de Apache falle.

 

Resolution

Para confirmar un problema con el archivo httpd.conf, compruebe las instancias de error relacionadas con la salida inesperada de Apache y Tomcat mediante los siguientes comandos:

/nas/tools/dbchk -wvxpV
nas_logviewer /nas/log/sys_log | grep -i apache | tail
nas_logviewer /nas/log/sys_log | grep -i tomcat | tail
cat /var/log/messages | grep -i tomcat | tail
cat /var/log/messages | grep -i apache | tail
cat /nas/tomcat/logs/catalina.out  | grep -i error | tail

Compruebe si hay errores de sintaxis en el archivo apache_restart.out mediante el siguiente comando:

cat /nas/http/logs/apache_restart.out | grep -i syntax | tail

Para confirmar problemas con el archivo httpd.conf
:Realice un vi o menos en el archivo /nas/http/conf/httpd.conf y busque el número de línea que ve con el error de sintaxis de apache_restart.out. Luego, verifique el mismo archivo y número de línea en un arreglo de laboratorio para determinar dónde está el espacio adicional o el carácter incorrecto/faltante y edítelo para resolverlo.

Después de confirmar un problema de edición con el archivo httpd.conf:
Para el ejemplo de SSLCipherSuite, editaría y eliminaría el espacio adicional en esa línea para cambiarla de una línea dividida en dos líneas a una sola línea:

< # SSL Cipher Suite:
< # List the ciphers that the client is permitted to negotiate.
< # See the mod_ssl documentation for a complete list.
< #SSLCipherSuite ALL:!ADH:!DH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:-MEDIUM:-LOW
< SSLCipherSuite
< ALL:!ADH:!DH:!EXPORT:!SSLv2:+HIGH:-MEDIUM:-LOW

Después de quitar el espacio adicional, se vería así:

< # SSL Cipher Suite:
< # List the ciphers that the client is permitted to negotiate.
< # See the mod_ssl documentation for a complete list.
< #SSLCipherSuite ALL:!ADH:!DH:!EXPORT:!SSLv2:+HIGH:-MEDIUM:-LOW
< SSLCipherSuite ALL:!ADH:!DH:!EXPORT:!SSLv2:+HIGH:-MEDIUM:-LOW

Después de corregir el error de edición en el archivo httpd.conf, confirme que los errores se hayan detenido; para ello, revise los registros nuevamente con:

tail -f on /var/log/messages

Y

/nas/http/logs/apache_restart.out

Los errores tienden a ser streaming y se detienen justo después de corregir la edición problemática.
Recordar: El anterior es un ejemplo para mostrar un espacio agregado a una sola línea que lo divide y hace que sean dos líneas separadas en el archivo. Pero tendría que evaluar caso por caso y corregir en consecuencia, ya sean espacios adicionales, espacios eliminados o errores tipográficos.

 

Additional Information

En /nas/log/syslog:

# nas_logviewer /nas/log/sys_log | grep -i apache | tail -5

Sep 11 11:48:25 2019:CS_PLATFORM:MasterControl:EMERGENCY:6:::::Daemon Apache daemon unexpectedly exited (status = 0); ifexit=1, exitstatus=0, ifsignal=0, termsig=0, ifstop=0, stopsig=0, ifdump=0.
Sep 11 11:48:25 2019:CS_PLATFORM:MasterControl:EMERGENCY:6:::::Daemon Apache daemon unexpectedly exited (status = 0); ifexit=1, exitstatus=0, ifsignal=0, termsig=0, ifstop=0, stopsig=0, ifdump=0.
Sep 11 11:48:25 2019:CS_PLATFORM:MasterControl:EMERGENCY:6:::::Daemon Apache daemon unexpectedly exited (status = 0); ifexit=1, exitstatus=0, ifsignal=0, termsig=0, ifstop=0, stopsig=0, ifdump=0.
Sep 11 11:48:26 2019:CS_PLATFORM:MasterControl:EMERGENCY:6:::::Daemon Apache daemon unexpectedly exited (status = 0); ifexit=1, exitstatus=0, ifsignal=0, termsig=0, ifstop=0, stopsig=0, ifdump=0.
Sep 11 11:48:26 2019:CS_PLATFORM:MasterControl:EMERGENCY:15:::::Apache daemon respawning too fast; disabled for 5 minutes.

De /nas/tomcat/logs/catalina.out: Puede ver el mensaje "GRAVE: Error al decodificar la solicitud".

Aug 28, 2019 8:23:31 PM org.apache.jk.common.ChannelSocket processConnection
WARNING: processCallbacks status 2
Aug 28, 2019 8:23:31 PM org.apache.jk.common.HandlerRequest invoke
SEVERE: Error decoding request
java.io.CharConversionException: Invalid char in port: 58
at org.apache.jk.common.HandlerRequest.parseHost(HandlerRequest.java:658)
at org.apache.jk.common.HandlerRequest.decodeRequest(HandlerRequest.java:404)
at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:261)
at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:767)
at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:697)
at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:889)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
at java.lang.Thread.run(Unknown Source)
Aug 28, 2019 8:23:31 PM org.apache.jk.common.ChannelSocket processConnection
WARNING: processCallbacks status 2
Wed Sep 4 10:24:48 CDT 2019 Starting tomcat web server.

Si por alguna razón es necesario reiniciar Tomcat, Apache y httpd después de confirmar que el archivo httpd.conf no tiene más problemas, puede hacerlo mediante este comando:

/nas/http/nas_ezadm/etc/script restart

Se debe tener en cuenta que reiniciar Apache/Tomcat/httpd por sí solo no tiene ningún efecto si se trata de un problema confirmado o un error en la edición del archivo, hasta después de que se corrija el error de edición. Si el archivo httpd.conf tiene alguna sintaxis incorrecta, verá "SEVERE: Catalina.stop: java.net.ConnectException: Conexión rechazada (Conexión rechazada)" que aparecía durante el reinicio de los servicios.

Además, puede comprobar un comando getagent normal:

/nas/sbin/naviseccli -h SPA getagent

Y luego, también verifique las credenciales de seguridad para asegurarse de que no haya problemas:

# /nas/sbin/naviseccli -h SPA -user sysadmin -password sysadmin -scope 0 getagent

Agent Rev: 7.33.9 (2.36)
Name: K10
Desc:
Node: A-APM00xxxxxxxxx
Physical Node: K10
Signature: 3854449
Peer Signature: 3698693
Revision: 05.33.009.5.238
SCSI Id: 0
Model: VNX7600
Model Type: Rackmount
Prom Rev: 33.51.00
SP Memory: 65536
Serial No: APM00xxxxxxxxx
SP Identifier: A
Cabinet: DPE9

Si el comando security naviseccli falla, realice una búsqueda de KBA utilizando lo siguiente para encontrar varios artículos de KB relacionados:

VNX:   /nas/sbin/naviseccli -h SPA -user <user> -password <password> -scope 0 getagent

 

Affected Products

VNX/VNXe

Products

VNX/VNXe
Article Properties
Article Number: 000056127
Article Type: Solution
Last Modified: 21 Nov 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.