Dell VNX: Det går inte att komma åt Unispheres UI-webbgränssnitt efter uppgradering

Summary: Efter en OE-koduppgradering blev Unisphere otillgängligt och filen httpd.conf återgick till standardinställningarna och vid redigering angavs ett extra mellanslag, vilket orsakade problem med apacheskriptet. (kan korrigeras av användaren) ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Flare OE- och NAS-uppgraderingar.

Det går inte att komma åt Unisphere-webbgränssnittet efter en OE Flare- och NAS-koduppgradering. Unisphere blev otillgängligt, httpd.conf-filen återställdes till standardinställningarna och vid redigering angavs ett extra mellanslag, vilket orsakade problem med Apache-skriptet.

 

Cause

Kunden var tvungen att redigera om /nas/http/conf/httpd.conf efter en uppgradering eftersom filen återställs till standardinställningarna.
I det här fallet var kunden tvungen att lägga till säkerhetschiffer på SSLCipherSuite-raden. Alla redigeringsmisstag, till exempel att lämna ett extra utrymme i filen, kan dock göra att Apache-skriptet misslyckas.

 

Resolution

Om du vill bekräfta ett problem med filen httpd.conf kontrollerar du felinstanser angående Apache och Tomcat "oväntat avslutade" med följande kommandon:

/nas/tools/dbchk -wvxpV
nas_logviewer /nas/log/sys_log | grep -i apache | tail
nas_logviewer /nas/log/sys_log | grep -i tomcat | tail
cat /var/log/messages | grep -i tomcat | tail
cat /var/log/messages | grep -i apache | tail
cat /nas/tomcat/logs/catalina.out  | grep -i error | tail

Sök efter syntaxfel i apache_restart.out-filen med följande kommando:

cat /nas/http/logs/apache_restart.out | grep -i syntax | tail

Så här bekräftar du problem med httpd.conf:
Gör ett vi eller mindre i filen /nas/http/conf/httpd.conf och sök efter radnumret som du ser med syntaxfelet från apache_restart.out. Kontrollera sedan samma fil- och radnummer i en labbmatris för att avgöra var det extra blanksteget eller det felaktiga/saknade tecknet finns och redigera för att lösa problemet.

Efter att ha bekräftat ett redigeringsproblem med httpd.conf-filen:
För SSLCipherSuite-exemplet skulle du redigera och ta bort det extra utrymmet på den raden för att ändra det från en rad uppdelad i två rader tillbaka till en enda rad:

< # SSL Cipher Suite:
< # List the ciphers that the client is permitted to negotiate.
< # See the mod_ssl documentation for a complete list.
< #SSLCipherSuite ALL:!ADH:!DH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:-MEDIUM:-LOW
< SSLCipherSuite
< ALL:!ADH:!DH:!EXPORT:!SSLv2:+HIGH:-MEDIUM:-LOW

När du har tagit bort det extra utrymmet skulle det se ut så här:

< # SSL Cipher Suite:
< # List the ciphers that the client is permitted to negotiate.
< # See the mod_ssl documentation for a complete list.
< #SSLCipherSuite ALL:!ADH:!DH:!EXPORT:!SSLv2:+HIGH:-MEDIUM:-LOW
< SSLCipherSuite ALL:!ADH:!DH:!EXPORT:!SSLv2:+HIGH:-MEDIUM:-LOW

När du har åtgärdat redigeringsmisstaget i httpd.conf-filen bekräftar du att felen har upphört genom att granska loggarna igen med:

tail -f on /var/log/messages

Och

/nas/http/logs/apache_restart.out

Felen tenderar att strömma och stoppas direkt efter att du har åtgärdat problemredigeringen.
Komma ihåg: Ovanstående är ett exempel för att visa ett blanksteg som läggs till på en enda rad som bryter upp det och gör att det blir två separata rader i filen. Men du måste bedöma från fall till fall och åtgärda därefter, oavsett om det är extra mellanslag, borttagna mellanslag eller stavfel.

 

Additional Information

Från /nas/log/syslog:

# nas_logviewer /nas/log/sys_log | grep -i apache | tail -5

Sep 11 11:48:25 2019:CS_PLATFORM:MasterControl:EMERGENCY:6:::::Daemon Apache daemon unexpectedly exited (status = 0); ifexit=1, exitstatus=0, ifsignal=0, termsig=0, ifstop=0, stopsig=0, ifdump=0.
Sep 11 11:48:25 2019:CS_PLATFORM:MasterControl:EMERGENCY:6:::::Daemon Apache daemon unexpectedly exited (status = 0); ifexit=1, exitstatus=0, ifsignal=0, termsig=0, ifstop=0, stopsig=0, ifdump=0.
Sep 11 11:48:25 2019:CS_PLATFORM:MasterControl:EMERGENCY:6:::::Daemon Apache daemon unexpectedly exited (status = 0); ifexit=1, exitstatus=0, ifsignal=0, termsig=0, ifstop=0, stopsig=0, ifdump=0.
Sep 11 11:48:26 2019:CS_PLATFORM:MasterControl:EMERGENCY:6:::::Daemon Apache daemon unexpectedly exited (status = 0); ifexit=1, exitstatus=0, ifsignal=0, termsig=0, ifstop=0, stopsig=0, ifdump=0.
Sep 11 11:48:26 2019:CS_PLATFORM:MasterControl:EMERGENCY:15:::::Apache daemon respawning too fast; disabled for 5 minutes.

Från /nas/tomcat/logs/catalina.out: Du kan se ett "ALLVARLIG: Fel vid avkodningsbegäran".

Aug 28, 2019 8:23:31 PM org.apache.jk.common.ChannelSocket processConnection
WARNING: processCallbacks status 2
Aug 28, 2019 8:23:31 PM org.apache.jk.common.HandlerRequest invoke
SEVERE: Error decoding request
java.io.CharConversionException: Invalid char in port: 58
at org.apache.jk.common.HandlerRequest.parseHost(HandlerRequest.java:658)
at org.apache.jk.common.HandlerRequest.decodeRequest(HandlerRequest.java:404)
at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:261)
at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:767)
at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:697)
at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:889)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
at java.lang.Thread.run(Unknown Source)
Aug 28, 2019 8:23:31 PM org.apache.jk.common.ChannelSocket processConnection
WARNING: processCallbacks status 2
Wed Sep 4 10:24:48 CDT 2019 Starting tomcat web server.

Om en omstart av Tomcat, Apache och httpd av någon anledning behövs efter att du har bekräftat att filen httpd.conf inte har några ytterligare problem, kan du göra det med det här kommandot:

/nas/http/nas_ezadm/etc/script restart

Det bör noteras att enbart omstart av Apache/Tomcat/httpd inte har någon effekt om detta är ett bekräftat problem eller misstag i vi-redigering av filen, förrän efter att redigeringsmisstaget har korrigerats. Om httpd.conf-filen har någon felaktig syntax visas "SEVERE: Catalina.stop: java.net.ConnectException: Anslutning nekad (Anslutning nekad)", fel som skulle visas när tjänsterna startas om.

Du kan också kontrollera ett vanligt getagent-kommando:

/nas/sbin/naviseccli -h SPA getagent

Kontrollera sedan även säkerhetscreds för att vara säker på att det inte finns några problem:

# /nas/sbin/naviseccli -h SPA -user sysadmin -password sysadmin -scope 0 getagent

Agent Rev: 7.33.9 (2.36)
Name: K10
Desc:
Node: A-APM00xxxxxxxxx
Physical Node: K10
Signature: 3854449
Peer Signature: 3698693
Revision: 05.33.009.5.238
SCSI Id: 0
Model: VNX7600
Model Type: Rackmount
Prom Rev: 33.51.00
SP Memory: 65536
Serial No: APM00xxxxxxxxx
SP Identifier: A
Cabinet: DPE9

Om kommandot security naviseccli misslyckas gör du en KBA-sökning med hjälp av följande för att hitta flera relaterade KB-artiklar:

VNX:   /nas/sbin/naviseccli -h SPA -user <user> -password <password> -scope 0 getagent

 

Affected Products

VNX/VNXe

Products

VNX/VNXe
Article Properties
Article Number: 000056127
Article Type: Solution
Last Modified: 21 Nov 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.