Dell VNX:升级后无法访问 Unisphere UI Web 界面

Summary: 在 OE 代码升级 Unisphere 变得不可访问后,httpd.conf 文件恢复为默认值,并且在编辑时输入了一个额外的空格,导致 apache 脚本出现问题。(用户可纠正)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Flare OE 和 NAS 升级。

OE Flare 和 NAS 代码升级后无法访问 Unisphere Web 界面。Unisphere 变得不可访问,httpd.conf 文件恢复为默认值,并且在编辑时输入了额外的空间,导致 Apache 脚本出现问题。

 

Cause

客户必须在升级后重新编辑 /nas/http/conf/httpd.conf,因为文件将恢复为默认设置。
在这种情况下,客户必须在 SSLCipherSuite 行上重新添加安全密码。但是,编辑中的任何错误(例如在文件中留出额外的空间)都可能导致 Apache 脚本失败。

 

Resolution

要确认 httpd.conf 文件的问题,请使用以下命令检查有关 Apache 和 Tomcat “意外退出”的错误实例:

/nas/tools/dbchk -wvxpV
nas_logviewer /nas/log/sys_log | grep -i apache | tail
nas_logviewer /nas/log/sys_log | grep -i tomcat | tail
cat /var/log/messages | grep -i tomcat | tail
cat /var/log/messages | grep -i apache | tail
cat /nas/tomcat/logs/catalina.out  | grep -i error | tail

使用以下命令检查 apache_restart.out 文件中的语法错误:

cat /nas/http/logs/apache_restart.out | grep -i syntax | tail

要确认 httpd.conf 的问题:
对 /nas/http/conf/httpd.conf 文件执行 vi 或更少命令,然后搜索您看到的带有 apache_restart.out 语法错误的行号。然后检查实验阵列上的相同文件和行号,以确定多余空间或错误/缺失字符的位置,并进行编辑以解决问题。

确认 httpd.conf 文件的编辑问题后:
对于 SSLCipherSuite 示例,您将编辑并删除该行上的额外空间,以将其从一行分成两行更改为一行:

< # SSL Cipher Suite:
< # List the ciphers that the client is permitted to negotiate.
< # See the mod_ssl documentation for a complete list.
< #SSLCipherSuite ALL:!ADH:!DH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:-MEDIUM:-LOW
< SSLCipherSuite
< ALL:!ADH:!DH:!EXPORT:!SSLv2:+HIGH:-MEDIUM:-LOW

删除额外空间后,它将如下所示:

< # SSL Cipher Suite:
< # List the ciphers that the client is permitted to negotiate.
< # See the mod_ssl documentation for a complete list.
< #SSLCipherSuite ALL:!ADH:!DH:!EXPORT:!SSLv2:+HIGH:-MEDIUM:-LOW
< SSLCipherSuite ALL:!ADH:!DH:!EXPORT:!SSLv2:+HIGH:-MEDIUM:-LOW

修复 httpd.conf 文件中的编辑错误后,使用以下命令再次查看日志,确认错误已停止:

tail -f on /var/log/messages

/nas/http/logs/apache_restart.out

这些错误往往是流式传输,并在您解决问题编辑后立即停止。
记得:上面是一个示例,显示了添加到单行中的空格,将其分解并导致它在文件中成为两行单独的行。但是您必须根据具体情况进行评估,并相应地修复多余的空格、删除的空格或错别字。

 

Additional Information

从/nas/log/syslog:

# nas_logviewer /nas/log/sys_log | grep -i apache | tail -5

Sep 11 11:48:25 2019:CS_PLATFORM:MasterControl:EMERGENCY:6:::::Daemon Apache daemon unexpectedly exited (status = 0); ifexit=1, exitstatus=0, ifsignal=0, termsig=0, ifstop=0, stopsig=0, ifdump=0.
Sep 11 11:48:25 2019:CS_PLATFORM:MasterControl:EMERGENCY:6:::::Daemon Apache daemon unexpectedly exited (status = 0); ifexit=1, exitstatus=0, ifsignal=0, termsig=0, ifstop=0, stopsig=0, ifdump=0.
Sep 11 11:48:25 2019:CS_PLATFORM:MasterControl:EMERGENCY:6:::::Daemon Apache daemon unexpectedly exited (status = 0); ifexit=1, exitstatus=0, ifsignal=0, termsig=0, ifstop=0, stopsig=0, ifdump=0.
Sep 11 11:48:26 2019:CS_PLATFORM:MasterControl:EMERGENCY:6:::::Daemon Apache daemon unexpectedly exited (status = 0); ifexit=1, exitstatus=0, ifsignal=0, termsig=0, ifstop=0, stopsig=0, ifdump=0.
Sep 11 11:48:26 2019:CS_PLATFORM:MasterControl:EMERGENCY:15:::::Apache daemon respawning too fast; disabled for 5 minutes.

从 /nas/tomcat/logs/catalina.out:您可以看到“SEVERE:Error decoding request“消息。

Aug 28, 2019 8:23:31 PM org.apache.jk.common.ChannelSocket processConnection
WARNING: processCallbacks status 2
Aug 28, 2019 8:23:31 PM org.apache.jk.common.HandlerRequest invoke
SEVERE: Error decoding request
java.io.CharConversionException: Invalid char in port: 58
at org.apache.jk.common.HandlerRequest.parseHost(HandlerRequest.java:658)
at org.apache.jk.common.HandlerRequest.decodeRequest(HandlerRequest.java:404)
at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:261)
at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:767)
at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:697)
at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:889)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
at java.lang.Thread.run(Unknown Source)
Aug 28, 2019 8:23:31 PM org.apache.jk.common.ChannelSocket processConnection
WARNING: processCallbacks status 2
Wed Sep 4 10:24:48 CDT 2019 Starting tomcat web server.

如果在确认 httpd.conf 文件没有进一步的问题后出于任何原因需要重新启动 Tomcat、Apache 和 httpd,您可以使用以下命令执行此作:

/nas/http/nas_ezadm/etc/script restart

应该注意的是,如果这是文件的 vi 编辑中的已确认问题或错误,则单独重新启动 Apache/Tomcat/httpd 是无效的,直到编辑错误得到纠正。如果 httpd.conf 文件有任何错误的语法,您会看到“SEVERE:Catalina.stop: java.net.ConnectException:Connection refused(Connection refused)“错误,该错误将在服务重新启动期间出现。

此外,您还可以检查常规 getagent 命令:

/nas/sbin/naviseccli -h SPA getagent

然后,还要检查安全凭据以确保没有问题:

# /nas/sbin/naviseccli -h SPA -user sysadmin -password sysadmin -scope 0 getagent

Agent Rev: 7.33.9 (2.36)
Name: K10
Desc:
Node: A-APM00xxxxxxxxx
Physical Node: K10
Signature: 3854449
Peer Signature: 3698693
Revision: 05.33.009.5.238
SCSI Id: 0
Model: VNX7600
Model Type: Rackmount
Prom Rev: 33.51.00
SP Memory: 65536
Serial No: APM00xxxxxxxxx
SP Identifier: A
Cabinet: DPE9

如果 security naviseccli 命令失败,请使用以下内容执行 KBA 搜索,以查找几篇相关的知识库文章:

VNX:   /nas/sbin/naviseccli -h SPA -user <user> -password <password> -scope 0 getagent

 

Affected Products

VNX/VNXe

Products

VNX/VNXe
Article Properties
Article Number: 000056127
Article Type: Solution
Last Modified: 21 Nov 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.