Integración de Avamar y Data Domain: Cómo borrar la caché de tokens en MCS y Data Domain

Summary: Integración de Avamar y Data Domain: Cómo borrar la caché de tokens en MCS y Data Domain

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Los siguientes errores pueden observarse durante los respaldos fallidos de Avamar en Data Domain en los registros de respaldo extraídos de la GUI de Avamar Administrator:

avtar Warning <18125>: Calling DDR_OPEN_VIA_TOKEN returned result code:5341 message:SSL library error
or
avtar Error <41439>: Using invalid token:<token>
avtar Error <10542>: Data Domain server "<ddhostname>" open failed DDR result code: 4904, desc: Invalid API argument.

Cause

Es posible que los tokens almacenados en la caché de tokens en MCS o en Data Domain se hayan vuelto obsoletos y se deban borrar.

Resolution

Este proceso borrará cualquier almacenamiento en caché de tokens tanto en MCS como en Data Domain, y puede resolver fallas de conexión de cliente Avamar a Data Domain con errores de token:

  • Abra una sesión de PuTTY en Avamar como usuario administrador
  • Compruebe la información de Data Domain presente en Avamar. El nombre de host de DD y el nombre de usuario de DDBoost se requerirán más adelante en este procedimiento.
    ddrmaint read-ddr-info
    	
  • Confirme que no haya tareas de mantenimiento en ejecución en el sistema (recolección de elementos no utilizados, comprobación de HFS o punto de control):
    status.dpn
    	
  • Coloque el sistema en un estado controlado correcto:
    dpnctl stop maint,sched
    	
  • Verifique que no haya respaldos en ejecución en Avamar y que no se ejecuten respaldos de ddboost en Data Domain:
    avmaint sessions | grep sessionid
    	
  • Si hay respaldos en ejecución en Avamar, se pueden cancelar a través de Avamar Administrator/AUI o desde la línea de comandos con:
    avmaint kill <sessionid>
    	
  • Abra una sesión de PuTTY en Data Domain como usuario sysadmin y verifique que no haya respaldos en ejecución mediante DDBoost:
    ddboost streams show active all
    	
  • Si no hay bakcups en ejecución, detenga MCS y ddrmaint-service en el servidor Avamar:
    dpnctl stop mcs,ddrmaint-service
    	
  • A continuación, abra la sesión de PuTTY en Data Domain y revoque el acceso al token para el usuario ddboost desde la línea de comandos de Data Domain. El valor de <ddboost_username> debe haberse obtenido previamente en el primer comando
    ddboost user revoke token-access <ddboost_username
    	
  • Detenga e inicie el servicio ddboost en la línea de comandos de Data Domain:
    ddboost disable
    ddboost enable
    	
  • Abra la sesión putty de Avamar e inicie los servicios de Avamar:
    dpnctl start mcs,sched,maint,ddrmaint-service
    	
  • Actualice la configuración de Data Domain en MCS desde la línea de comandos de Avamar. El valor de <dd_hostname> debe haberse obtenido previamente en el primer comando
    mccli dd edit --name=<dd_hostname>
    	
  • Realice un respaldo de prueba para confirmar que se pueda ejecutar correctamente
  • Si los respaldos continúan fallando con los errores mencionados después de borrar la caché de tokens, abra una nueva solicitud de servicio con el soporte de Avamar para solucionar más este problema.

Affected Products

Avamar

Products

Avamar, Data Domain, Integrated Data Protection Appliance Family
Article Properties
Article Number: 000056240
Article Type: Solution
Last Modified: 24 Aug 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.