VM-Backups schlagen mit vCenter-Anmeldefehlern fehl

Summary: Backups schlagen fehl, wenn Regeln oder Tags verwendet werden.

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Symptoms

VM-Backups, die Regeln oder Tags verwenden, schlagen fehl.
Reguläre Backups abgeschlossen – mithilfe der Policy ausgewählt

Protokolle zeigen den folgenden Fehler an:

Action backup vmware-vproxy 'backup' has initialized as 'vproxysave job' with job id 224276
libCURL SSL support is Enabled.
Inventory session status returned with a failure. Error: 'Failed to load inventory from 'VCenter_server.FQN.com': ServerFaultCode: Cannot complete login due to an incorrect user name or password.'.

Und:

NWSERVERNAME nsrdisp_nwbg NSR critical Inventory session status returned with a failure. Error: 'Failed to load inventory from 'VCENTER_NAME': ServerFaultCode: Cannot complete login due to an incorrect user name or password.'.
lNWSERVERNAME nsrdisp_nwbg NSR notice
Reading the XML from RAP without running nsrvim again

 

Cause

Der Nutzer und/oder das Kennwort wurden für das VM-Backup geändert.

nsrvisd verwendet das Kennwort.
Die Änderung wurde nie im nsrvisd-Bestandsaufnahmeprozess widergespiegelt.

Überprüfen Sie die Protokolle in:
/nsr/vproxy/logs/nsrvisd
Oder
/opt/nsr/vproxy/logs/nsrvisd

Das Protokoll spiegelt den alten Nutzer wider – das Kennwort sollte verschlüsselt werden.

Resource Definition: {"Config":{"SessionId":"92-23993-9966cdbbd1","LogTag":"@(#) Build number: 41","LogLevel":"INFO","IdleTimeout":0,"AcceptedLanguage":"","VimServer":{"HostName":"VCENTER_SERVER","TcpPort":443,"UserName":"administrator@vsphere.local","UserPassword":"********","ThumbPrint":"","HypervisorMode":"vSphere"},"RefreshInventory":10},"Actions":{"ChangeSession":"/api/v1/InventorySessions/92fba-7a3a-48eb-84-e706cdbbd1","DeleteSession":"/api/v1/InventorySessions/92fbeef3a-48eb-84a6-70736cdbbd1","CancelActivity":"/api/v1/InventorySessions/92fbeefa-7a3a-48eb-84a6-e70736cdbbd1/activity","GetSession":"/api/v1/InventorySessions/92fbe

 

Resolution

Dies ist ein Problem, für das eine technische Untersuchung durch Dell läuft.

Die Problemumgehung besteht darin, die Statusdatei zu löschen - InventorySessions.gob

Die Statusdatei finden Sie unter.
/nsr/vproxy/logs/nsrvisd/InventorySessions.gob
ODER
/opt/nsr/vproxy/logs/nsrvisd/InventorySessions.gob

Benennen Sie InventorySessions.gob um.
mv InventorySessions.gob InventorySessions.gob_old

Beenden Sie nsrvisd mit kill.

ps -eaf | grep nsrvisd
kill <pid>

NSRVISD wird neu gestartet.
Überprüfen Sie, ob er neu gestartet wurde:

ps -eaf | grep nsrvisd

 

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000056263
Article Type: Solution
Last Modified: 04 Dec 2025
Version:  4
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