VM 備份失敗,並出現 vCenter 登入錯誤

Summary: 使用規則或標籤時,備份失敗。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

使用規則或標記的 VM 備份失敗。
定期備份已完成 - 使用原則選擇

記錄顯示以下錯誤:

Action backup vmware-vproxy 'backup' has initialized as 'vproxysave job' with job id 224276
libCURL SSL support is Enabled.
Inventory session status returned with a failure. Error: 'Failed to load inventory from 'VCenter_server.FQN.com': ServerFaultCode: Cannot complete login due to an incorrect user name or password.'.

和:

NWSERVERNAME nsrdisp_nwbg NSR critical Inventory session status returned with a failure. Error: 'Failed to load inventory from 'VCENTER_NAME': ServerFaultCode: Cannot complete login due to an incorrect user name or password.'.
lNWSERVERNAME nsrdisp_nwbg NSR notice
Reading the XML from RAP without running nsrvim again

 

Cause

VM 備份的使用者或密碼或兩者均已變更。

nsrvisd 正在使用密碼。
此變更並未反映在 nsrvisd 清查程序中。

檢閱以下位置的記錄:
/nsr/vproxy/logs/nsrvisd

/opt/nsr/vproxy/logs/nsrvisd

記錄會反映舊使用者 - 密碼應加密。

Resource Definition: {"Config":{"SessionId":"92-23993-9966cdbbd1","LogTag":"@(#) Build number: 41","LogLevel":"INFO","IdleTimeout":0,"AcceptedLanguage":"","VimServer":{"HostName":"VCENTER_SERVER","TcpPort":443,"UserName":"administrator@vsphere.local","UserPassword":"********","ThumbPrint":"","HypervisorMode":"vSphere"},"RefreshInventory":10},"Actions":{"ChangeSession":"/api/v1/InventorySessions/92fba-7a3a-48eb-84-e706cdbbd1","DeleteSession":"/api/v1/InventorySessions/92fbeef3a-48eb-84a6-70736cdbbd1","CancelActivity":"/api/v1/InventorySessions/92fbeefa-7a3a-48eb-84a6-e70736cdbbd1/activity","GetSession":"/api/v1/InventorySessions/92fbe

 

Resolution

這是一個問題,Dell 工程調查正在進行中。

因應措施是清除狀態檔案 - InventorySessions.gob

狀態檔可以位於 下。
/nsr/vproxy/logs/nsrvisd/InventorySessions.gob

/opt/nsr/vproxy/logs/nsrvisd/InventorySessions.gob

重新命名 InventorySessions.gob。
mv InventorySessions.gob InventorySessions.gob_old

停止 nsrvisd - 使用 kill。

ps -eaf | grep nsrvisd
kill <pid>

NSRVISD 已重新啟動。
確認其已重新開機:

ps -eaf | grep nsrvisd

 

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000056263
Article Type: Solution
Last Modified: 04 Dec 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.