VM-sikkerhedskopieringer mislykkes med vCenter-loginfejl

Summary: Sikkerhedskopieringer mislykkes, når du bruger regler eller tags.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

VM-sikkerhedskopieringer, der bruger regler eller tags, mislykkes.
Regelmæssig sikkerhedskopiering fuldført – valgt ved hjælp af politikken

Logfiler viser følgende fejl:

Action backup vmware-vproxy 'backup' has initialized as 'vproxysave job' with job id 224276
libCURL SSL support is Enabled.
Inventory session status returned with a failure. Error: 'Failed to load inventory from 'VCenter_server.FQN.com': ServerFaultCode: Cannot complete login due to an incorrect user name or password.'.

Og:

NWSERVERNAME nsrdisp_nwbg NSR critical Inventory session status returned with a failure. Error: 'Failed to load inventory from 'VCENTER_NAME': ServerFaultCode: Cannot complete login due to an incorrect user name or password.'.
lNWSERVERNAME nsrdisp_nwbg NSR notice
Reading the XML from RAP without running nsrvim again

 

Cause

Brugeren eller adgangskoden eller begge blev ændret til VM-sikkerhedskopiering.

nsrvisd bruger adgangskoden.
Ændringen blev aldrig afspejlet i nsrvisd-opgørelsesprocessen.

Gennemse logfilerne på:
/nsr/vproxy/logs/nsrvisd
Eller
/opt/nsr/vproxy/logs/nsrvisd

Loggen afspejler den gamle bruger - adgangskoden skal krypteres.

Resource Definition: {"Config":{"SessionId":"92-23993-9966cdbbd1","LogTag":"@(#) Build number: 41","LogLevel":"INFO","IdleTimeout":0,"AcceptedLanguage":"","VimServer":{"HostName":"VCENTER_SERVER","TcpPort":443,"UserName":"administrator@vsphere.local","UserPassword":"********","ThumbPrint":"","HypervisorMode":"vSphere"},"RefreshInventory":10},"Actions":{"ChangeSession":"/api/v1/InventorySessions/92fba-7a3a-48eb-84-e706cdbbd1","DeleteSession":"/api/v1/InventorySessions/92fbeef3a-48eb-84a6-70736cdbbd1","CancelActivity":"/api/v1/InventorySessions/92fbeefa-7a3a-48eb-84a6-e70736cdbbd1/activity","GetSession":"/api/v1/InventorySessions/92fbe

 

Resolution

Dette er et problem, og Dells tekniske undersøgelse er i gang.

Løsningen er at rydde tilstandsfilen - InventorySessions.gob

Tilstandsfilen kan findes under.
/nsr/vproxy/logs/nsrvisd/InventorySessions.gob
ELLER
/opt/nsr/vproxy/logs/nsrvisd/InventorySessions.gob

Omdøb InventorySessions.gob.
mv InventorySessions.gob InventorySessions.gob_old

Stop nsrvisd - ved hjælp af kill.

ps -eaf | grep nsrvisd
kill <pid>

NSRVISD genstartes.
Kontroller, at den blev genstartet:

ps -eaf | grep nsrvisd

 

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000056263
Article Type: Solution
Last Modified: 04 Dec 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.