Резервне копіювання віртуальних машин не працює через помилки входу в vCenter

Summary: Резервні копії не працюють при використанні правил або тегів.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Резервні копії віртуальних машин, які використовують правила або теги,
виходять з ладу.Регулярні резервні копії завершені — вибрано за допомогою політики

Журнали показують таку помилку:

Action backup vmware-vproxy 'backup' has initialized as 'vproxysave job' with job id 224276
libCURL SSL support is Enabled.
Inventory session status returned with a failure. Error: 'Failed to load inventory from 'VCenter_server.FQN.com': ServerFaultCode: Cannot complete login due to an incorrect user name or password.'.

І:

NWSERVERNAME nsrdisp_nwbg NSR critical Inventory session status returned with a failure. Error: 'Failed to load inventory from 'VCENTER_NAME': ServerFaultCode: Cannot complete login due to an incorrect user name or password.'.
lNWSERVERNAME nsrdisp_nwbg NSR notice
Reading the XML from RAP without running nsrvim again

 

Cause

Користувач, пароль або обидва були змінені для резервного копіювання віртуальної машини.

nsrvisd використовує пароль.
Ця зміна ніколи не була відображена у процесі інвентаризації nsrvisd.

Перегляньте логи:
/nsr/vproxy/logs/nsrvisd
Або
/opt/nsr/vproxy/logs/nsrvisd

Журнал відображає старого користувача — пароль має бути зашифрований.

Resource Definition: {"Config":{"SessionId":"92-23993-9966cdbbd1","LogTag":"@(#) Build number: 41","LogLevel":"INFO","IdleTimeout":0,"AcceptedLanguage":"","VimServer":{"HostName":"VCENTER_SERVER","TcpPort":443,"UserName":"administrator@vsphere.local","UserPassword":"********","ThumbPrint":"","HypervisorMode":"vSphere"},"RefreshInventory":10},"Actions":{"ChangeSession":"/api/v1/InventorySessions/92fba-7a3a-48eb-84-e706cdbbd1","DeleteSession":"/api/v1/InventorySessions/92fbeef3a-48eb-84a6-70736cdbbd1","CancelActivity":"/api/v1/InventorySessions/92fbeefa-7a3a-48eb-84a6-e70736cdbbd1/activity","GetSession":"/api/v1/InventorySessions/92fbe

 

Resolution

Це проблема, інженерне розслідування Dell триває.

Обхідний шлях — очистити файл стану - InventorySessions.gob

Файл штату можна знайти у розділі.
/nsr/vproxy/logs/nsrvisd/InventorySessions.gob
АБО
/opt/nsr/vproxy/logs/nsrvisd/InventorySessions.gob

Перейменуйте InventorySessions.gob.
mv InventorySessions.gob InventorySessions.gob_old

Зупиніть nsrvisd — використання вбивства.

ps -eaf | grep nsrvisd
kill <pid>

NSRVISD перезапущено.
Перевірте, що він перезавантажився:

ps -eaf | grep nsrvisd

 

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000056263
Article Type: Solution
Last Modified: 04 Dec 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.