虚拟机备份失败并显示 vCenter 登录错误
Summary: 使用规则或标记时备份失败。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
使用规则或标记的虚拟机备份失败。
常规备份完成 — 使用策略选择
日志显示以下错误:
Action backup vmware-vproxy 'backup' has initialized as 'vproxysave job' with job id 224276 libCURL SSL support is Enabled. Inventory session status returned with a failure. Error: 'Failed to load inventory from 'VCenter_server.FQN.com': ServerFaultCode: Cannot complete login due to an incorrect user name or password.'.
以及:
NWSERVERNAME nsrdisp_nwbg NSR critical Inventory session status returned with a failure. Error: 'Failed to load inventory from 'VCENTER_NAME': ServerFaultCode: Cannot complete login due to an incorrect user name or password.'. lNWSERVERNAME nsrdisp_nwbg NSR notice Reading the XML from RAP without running nsrvim again
Cause
已更改虚拟机备份的用户和/或密码。
nsrvisd 正在使用密码。
此更改从未反映在 nsrvisd 资源清册过程中。
查看以下位置的登录信息:/nsr/vproxy/logs/nsrvisd
或/opt/nsr/vproxy/logs/nsrvisd
日志反映了旧用户 — 密码应加密。
Resource Definition: {"Config":{"SessionId":"92-23993-9966cdbbd1","LogTag":"@(#) Build number: 41","LogLevel":"INFO","IdleTimeout":0,"AcceptedLanguage":"","VimServer":{"HostName":"VCENTER_SERVER","TcpPort":443,"UserName":"administrator@vsphere.local","UserPassword":"********","ThumbPrint":"","HypervisorMode":"vSphere"},"RefreshInventory":10},"Actions":{"ChangeSession":"/api/v1/InventorySessions/92fba-7a3a-48eb-84-e706cdbbd1","DeleteSession":"/api/v1/InventorySessions/92fbeef3a-48eb-84a6-70736cdbbd1","CancelActivity":"/api/v1/InventorySessions/92fbeefa-7a3a-48eb-84a6-e70736cdbbd1/activity","GetSession":"/api/v1/InventorySessions/92fbe
Resolution
这是一个问题,戴尔工程调查正在进行中。
解决方法是清除状态文件 - InventorySessions.gob
状态文件可以位于 下。/nsr/vproxy/logs/nsrvisd/InventorySessions.gob
或者/opt/nsr/vproxy/logs/nsrvisd/InventorySessions.gob
重命名 InventorySessions.gob。mv InventorySessions.gob InventorySessions.gob_old
Stop nsrvisd - using kill.
ps -eaf | grep nsrvisd kill <pid>
重新启动 NSRVISD。
验证它是否重新启动:
ps -eaf | grep nsrvisd
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000056263
Article Type: Solution
Last Modified: 04 Dec 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.