SourceOne Email Management: User login to SourceOne WebSearch fails due to restricted .net trust on Web services website.

Summary: User login to SourceOne WebSearch fails due to restricted .net trust on Web services website. The error Login Failed. Please try again is displayed.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Users are not able to login to SourceOne WebSearch with error "Login Failed. Please try again"

No errors are posted in any of the SourceOne logs, as the request for the login does not reach the Web services application on the server for login.

At the same time below errors are posted in the Application event viewer on the web services server which the search application is pointing to.
 

Source: ASP.NET 4.0.30319.0 Date: 8/1/2019 9:40:42 AM Event ID: 1314 Task Category: Web Event Level: Information Keywords: Classic User: N/A Computer: <ServerName> Description: Event code: 4010 Event message: An unhandled security exception has occurred. Event time: 8/1/2019 9:40:42 AM Event time (UTC): 8/1/2019 1:40:42 PM Event ID: c39b9b16ac5043f6bbcea94d2dc72704 Event sequence: 2 Event occurrence: 1 Event detail code: 0 Application information: Application domain: /LM/W3SVC/1/ROOT/SearchWS-1-132091404302779900 Trust level: Medium Application Virtual Path: /SearchWS Application Path: E:\Program Files (x86)\EMC SourceOne\SearchWS\WebServer\ Machine name: SOURCEONE Process information: Process ID: 19860 Process name: w3wp.exe Account name: <Domain\ServiceAccount> Request information: Request URL: http://sourceone/SearchWS/ExSearchWebService.asmx Request path: /SearchWS/ExSearchWebService.asmx User host address: fe80::19d9:2fcf:f229:abbE:\Program Files (x86)\EMC SourceOne\SearchWS\WebServer\ User: Is authenticated: False Authentication Type: Thread account name: <Domain\ServiceAccount>

Cause

This can be caused due to restriction .net trust configured on the SearchWS website.

Resolution

Change the trust level on the SearchWS website to FULL.

kA23a000000GDFiCAO_2_0

Restart IIS after changing .NET Trust Levels to FULL

Affected Products

SourceOne Email Management

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000056303
Article Type: Solution
Last Modified: 26 May 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.