Cisco MDS 9000-serien: Det går inte att konfigurera om Syslog-serverns IP-adress (sessionen ägs för närvarande av en annan användare)

Summary: Det går inte att konfigurera om Syslog-serverns IP-adress.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

När du försökte ändra IP-adressen för systemservern medan det fanns ett strukturlås till en annan användare på samma dator:
 

  1. Kunden kunde inte konfigurera om Syslog-serverns IP-adress. Avvisningsmeddelande (sessionen ägs för närvarande av en annan användare) visas.
  2. Cisco Fabric Service (CFS) är aktiverat för funktionen (syslogd) och användaren (USER_X) har låset medan kunden var inloggad med (USER_Y). 
`show cfs application`
----------------------------------------------
 Application    Enabled   Scope
----------------------------------------------
 ntp            No        Physical-fc-ip
 fscm           Yes       Physical-fc
 role           No        Physical-fc-ip
 rscn           No        Logical
 radius         No        Physical-fc-ip
 tacacs         No        Physical-fc-ip
 fctimer        No        Physical-fc
 syslogd        Yes       Physical-fc-ip
 callhome       No        Physical-fc-ip
 fcdomain       No        Logical
 fc-redirect    Yes       Physical-fc
 device-alias   Yes       Physical-fc

Total number of entries = 12

`show cfs lock`
Application: syslogd
Scope      : Physical-fc-ip
--------------------------------------------------------------------------------
 Switch WWN              IP Address                   User Name    User Type   
--------------------------------------------------------------------------------
 xx:xx:xx:xx:xx:xx:xx:xx XX.XX.XX.XX                   USER_X       CLI/SNMP v3 
                         <Switch name>

                       
 

Cause

Låsning av nätverket:

När du konfigurerar (förstagångskonfiguration) en Cisco NX-OS-funktion (eller applikation) som använder CFS-infrastrukturen (Cisco Fabric Services) startar en CFS-session och låser strukturen. När en struktur är låst tillåter Cisco NX-OS-programvaran inte konfigurationsändringar från switchar till den här funktionen, förutom switchen som håller låset. Den skickar ett meddelande för att informera användaren om låst status. Konfigurationsändringarna lagras i en väntande databas av det programmet.
Om du startar en CFS-session som kräver ett strukturlås men glömmer att avsluta sessionen kan en administratör rensa sessionen. Om du låser en struktur när som helst sparas ditt användarnamn vid omstarter och växlingar. Om en annan användare (på samma dator) försöker köra konfigurationsuppgifter avvisas den användarens försök.

Resolution

Alternativ lösning:

  1. Kontrollera utdata för (# show cfs lock name syslogd) för att se vilken switch/användare som har låset.
  2. Logga in på switchen/användaren har låset och utför de ändringar som krävs.

Lösning: Stoppa konfigurationen från switchen där konfigurationslåset förvärvades.

Den här metoden rensar CFS-låset för programmet (syslogd) i hela infrastrukturen:
Switch# Conf t
Switch(conf)# logging abort

Den här metoden rensar CFS-låset för programmet (syslogd) från alla switchar i strukturen:
Switch# clear logging session

Additional Information

En användare kan inte göra några konfigurationsrelaterade ändringar för motsvarande CFS-program, för vilka ett CFS-lås har fastnat, eller kan inte köra en programvaruuppgradering under drift (ISSU) om CFS är låst för session-mgr.

I den här listan visas några vanliga felmeddelanden som orsakas av ett CFS-lås:

  • Operation failed. Fabric is already locked.
  • Session currently owned by a different user.
  • Service "cfs" returned error: Operation failed. Fabric is already locked (0x40B30029)

Affected Products

Connectrix MDS-9513

Products

Connectrix MDS-9513, Connectrix MDS-Series Hardware
Article Properties
Article Number: 000056310
Article Type: Solution
Last Modified: 07 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.