Cisco MDS 9000 Serisi: Sistem günlüğü sunucusu IP'si yeniden yapılandırılamıyor (oturum şu anda farklı bir kullanıcıya ait)

Summary: Syslog sunucusu IP'si yeniden yapılandırılamıyor.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Aynı makinede başka bir kullanıcıya yapı kilidi varken Sistem Sunucusu IP adresini değiştirmeye çalışırken:
 

  1. Müşteri, Syslog sunucusu IP'sini yeniden yapılandıramadı. Ret mesajı (oturum şu anda farklı bir kullanıcıya ait) görüntülenir.
  2. Cisco Fabric Service (CFS), (syslogd) özelliği için etkinleştirilir ve müşteri (USER_Y) ile oturum açarken kullanıcı (USER_X) kilide sahiptir. 
`show cfs application`
----------------------------------------------
 Application    Enabled   Scope
----------------------------------------------
 ntp            No        Physical-fc-ip
 fscm           Yes       Physical-fc
 role           No        Physical-fc-ip
 rscn           No        Logical
 radius         No        Physical-fc-ip
 tacacs         No        Physical-fc-ip
 fctimer        No        Physical-fc
 syslogd        Yes       Physical-fc-ip
 callhome       No        Physical-fc-ip
 fcdomain       No        Logical
 fc-redirect    Yes       Physical-fc
 device-alias   Yes       Physical-fc

Total number of entries = 12

`show cfs lock`
Application: syslogd
Scope      : Physical-fc-ip
--------------------------------------------------------------------------------
 Switch WWN              IP Address                   User Name    User Type   
--------------------------------------------------------------------------------
 xx:xx:xx:xx:xx:xx:xx:xx XX.XX.XX.XX                   USER_X       CLI/SNMP v3 
                         <Switch name>

                       
 

Cause

Kumaşın Kilitlenmesi:

Cisco Fabric Services (CFS) altyapısını kullanan bir Cisco NX-OS özelliği (veya uygulaması) yapılandırılırken (ilk kez yapılandırma) bir CFS oturumu başlatılır ve yapı kilitlenir. Bir yapı kilitlendiğinde, Cisco NX-OS yazılımı, kilidi tutan anahtar dışında, anahtarlardan bu özelliğe yapılandırma değişikliklerine izin vermez. Kullanıcıyı kilitli durumu hakkında bilgilendirmek için bir mesaj yayınlar. Yapılandırma değişiklikleri, bu uygulama tarafından bekleyen bir veritabanında tutulur.
Yapı kilidi gerektiren bir CFS oturumu başlatır ancak oturumu sonlandırmayı unutursanız bir yönetici oturumu temizleyebilir. Bir yapıyı herhangi bir zamanda kilitlerseniz kullanıcı adınız yeniden başlatmalar ve geçişler arasında hatırlanır. Başka bir kullanıcı (aynı makinede) yapılandırma görevlerini çalıştırmaya çalışırsa, bu kullanıcının girişimleri reddedilir.

Resolution

Geçici Çözüm:

  1. Hangi Anahtarın/Kullanıcının kilide sahip olduğunu öğrenmek için (# show cfs lock name syslogd) çıktısını kontrol edin.
  2. Anahtarda oturum açın/Kullanıcı kilide sahiptir ve gerekli değişiklikleri yapın.

Çözünürlük: Yapılandırma kilidinin alındığı anahtardan yapılandırmayı durdurun.

Bu yöntem, yapının tamamında (syslogd) uygulaması için CFS kilidini temizler:
Switch# Conf t
Switch(conf)# logging abort

Bu yöntem, yapıdaki herhangi bir anahtardan (syslogd) uygulaması için CFS kilidini temizler:
Switch# clear logging session

Additional Information

Kullanıcı, CFS kilidinin takılı kaldığı ilgili CFS uygulamaları için yapılandırmayla ilgili herhangi bir değişiklik yapamaz veya CFS oturum-mgr için kilitlenmişse Hizmet İçi Yazılım Yükseltmesi (ISSU) çalıştıramaz.

Bu liste, CFS kilidinin neden olduğu bazı yaygın hata mesajlarını gösterir:

  • Operation failed. Fabric is already locked.
  • Session currently owned by a different user.
  • Service "cfs" returned error: Operation failed. Fabric is already locked (0x40B30029)

Affected Products

Connectrix MDS-9513

Products

Connectrix MDS-9513, Connectrix MDS-Series Hardware
Article Properties
Article Number: 000056310
Article Type: Solution
Last Modified: 07 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.