Серія Cisco MDS 9000: Не вдається повторно налаштувати IP-адресу сервера Syslog (сеанс, який наразі належить іншому користувачу)

Summary: Не вдається повторно налаштувати IP-адресу сервера Syslog.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

При спробі змінити IP-адресу системного сервера під час блокування тканини на іншого користувача на тому ж комп'ютері:
 

  1. Клієнт не зміг повторно налаштувати IP-адресу сервера Syslog. З'явиться повідомлення про відхилення (сеанс, який наразі належить іншому користувачу).
  2. Cisco Fabric Service (CFS) увімкнено для функції (syslogd), і користувач (USER_X) має блокування, тоді як клієнт увійшов у систему за допомогою (USER_Y). 
`show cfs application`
----------------------------------------------
 Application    Enabled   Scope
----------------------------------------------
 ntp            No        Physical-fc-ip
 fscm           Yes       Physical-fc
 role           No        Physical-fc-ip
 rscn           No        Logical
 radius         No        Physical-fc-ip
 tacacs         No        Physical-fc-ip
 fctimer        No        Physical-fc
 syslogd        Yes       Physical-fc-ip
 callhome       No        Physical-fc-ip
 fcdomain       No        Logical
 fc-redirect    Yes       Physical-fc
 device-alias   Yes       Physical-fc

Total number of entries = 12

`show cfs lock`
Application: syslogd
Scope      : Physical-fc-ip
--------------------------------------------------------------------------------
 Switch WWN              IP Address                   User Name    User Type   
--------------------------------------------------------------------------------
 xx:xx:xx:xx:xx:xx:xx:xx XX.XX.XX.XX                   USER_X       CLI/SNMP v3 
                         <Switch name>

                       
 

Cause

Фіксація тканини:

Під час налаштування (перша конфігурація) функції (або програми) Cisco NX-OS, яка використовує інфраструктуру Cisco Fabric Services (CFS), сеанс CFS запускається та блокує тканину. Коли тканина заблокована, програмне забезпечення Cisco NX-OS не дозволяє змінювати конфігурацію перемикачів на цю функцію, крім перемикача, що утримує замок. Він видає повідомлення для інформування користувача про статус блокування. Зміни конфігурації зберігаються в базі даних цього залу
.Якщо ви починаєте сеанс CFS, який вимагає блокування тканини, але забуваєте завершити сеанс, адміністратор може очистити сеанс. Якщо ви заблокуєте тканину в будь-який момент, ваше ім'я користувача запам'ятовується під час перезапуску та перемикання. Якщо інший користувач (на тому ж комп'ютері) намагається виконати завдання конфігурації, спроби цього користувача відхиляються.

Resolution

Спосіб вирішення:

  1. Перевірте вихідні дані (# показати ім'я замка cfs syslogd), щоб дізнатися, який Switch/User має блокування.
  2. Увійдіть у Switch/Користувач має блокування та виконайте необхідні зміни.

Резолюція: Зупиніть конфігурацію на перемикачі, де було отримано блокування конфігурації.

Цей метод очищає блокування CFS для застосування (syslogd) у всій тканині:
Switch# Conf t
Switch(conf)# logging abort

Цей метод очищає блокування CFS для програми (syslogd) з будь-якого перемикача в тканині:
Switch# clear logging session

Additional Information

Користувач не може внести будь-які зміни, пов'язані з конфігурацією, для відповідних додатків CFS, для яких застрягло блокування CFS, або не може запустити оновлення програмного забезпечення (ISSU), якщо CFS заблоковано для session-mgr.

Цей список містить деякі поширені повідомлення про помилки, спричинені блокуванням CFS:

  • Operation failed. Fabric is already locked.
  • Session currently owned by a different user.
  • Service "cfs" returned error: Operation failed. Fabric is already locked (0x40B30029)

Affected Products

Connectrix MDS-9513

Products

Connectrix MDS-9513, Connectrix MDS-Series Hardware
Article Properties
Article Number: 000056310
Article Type: Solution
Last Modified: 07 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.