VNX:Error: VNXからIsilonにアーカイブされたファイルを読み取ろうとすると、「Invalid handle request」(無効なハンドル要求が表示される) - Dell修正可能
Summary: Error: VNXからIsilonにアーカイブされたファイルを読み取ろうとすると、「Invalid handle request」が表示されます。(Dell Correctable)
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
DHSM接続に関連づけられている管理者アカウントが変更されました。
ある特定のファイル システムのアーカイブ ファイルは、エクスプローラーにグレーのXが表示され、読み取ることができません。これらのファイルはIsilon上に存在します。
これらのファイルの1つを読み取ろうとすると、VNX:
[nasadmin@xsbad10147 Contacts]$ ファイルB-Cards\Marubeni.PDF
B-Card Marubeni.PDFに次のログが記録されます。エラー:「BカードMarubeni.PDF」を読み取れません(入力/出力エラー)
2016-10-12 20:31:26: RPC: 5:CLIENT::CLIENT3 (avSvy) 0x009cfb8c08: ホスト x.x.x.x
2016-10-12 20:31:27 の Rpc サービス 1062247 バージョン 3 のポート取得に失敗しました: DHSM: 3:Cifs:エラー:オープン ソース ファイル\\xsbad10141-2.example.com\sfbad18502\.rffm_nas\0\0\60\8678に失敗しました。ntstatus:
INVALID_HANDLE2016-10-12 20:31:27: MGFSの3:エラー エントリー 222637 FSID 3285のダイレクト読み取りブロック0、ステータス28 - InternalError
ある特定のファイル システムのアーカイブ ファイルは、エクスプローラーにグレーのXが表示され、読み取ることができません。これらのファイルはIsilon上に存在します。
これらのファイルの1つを読み取ろうとすると、VNX:
[nasadmin@xsbad10147 Contacts]$ ファイルB-Cards\Marubeni.PDF
B-Card Marubeni.PDFに次のログが記録されます。エラー:「BカードMarubeni.PDF」を読み取れません(入力/出力エラー)
2016-10-12 20:31:26: RPC: 5:CLIENT::CLIENT3 (avSvy) 0x009cfb8c08: ホスト x.x.x.x
2016-10-12 20:31:27 の Rpc サービス 1062247 バージョン 3 のポート取得に失敗しました: DHSM: 3:Cifs:エラー:オープン ソース ファイル\\xsbad10141-2.example.com\sfbad18502\.rffm_nas\0\0\60\8678に失敗しました。ntstatus:
INVALID_HANDLE2016-10-12 20:31:27: MGFSの3:エラー エントリー 222637 FSID 3285のダイレクト読み取りブロック0、ステータス28 - InternalError
Cause
機能していないDHSM接続のIsilonへのセカンダリー ストレージ パスは、他の稼働中の接続と同じです。
機能しない接続で古い管理者アカウントを使用しているため、アーカイブされたファイルを読み取ろうとすると、Isilonから「Invalid handle request」が返されます。
正常に機能していない接続:
[nasadmin@xsbad10147 Contacts]$ fs_dhsm -c CIFS_GSGST -i
CIFS_GSGST:
state = enabled
offline attr = on
popup timeout = 0
backup = passthrough
read policy override = none
log file = on
max log size = 10MB
cid = 0
type = CIFS
secondary = \\xsbad10141-2.example.com\sfbad18502\
state = enabled
read policy override = none
write policy = full
local_server = SFBAD18502.EXAMPLE.COM
admin = example.com\s_bad1_fmadm
勝利 =
動作中の接続:
[nasadmin@xsbad10147 Contacts]$ fs_dhsm -c CIFS_T50_T3 -i
CIFS_GSGST:
state = enabled
offline attr = on
popup timeout = 0
backup = passthrough
read policy override = none
log file = on
max log size = 10MB
cid = 0
type = CIFS
secondary = \\xsbad10141-2.example.com\sfbad18502\
state = enabled
read policy override = none
write policy = full
local_server = SFBAD18502.EXAMPLE.COM
admin = example.com\s_bad1_fmadmin
の勝利=
機能しない接続で古い管理者アカウントを使用しているため、アーカイブされたファイルを読み取ろうとすると、Isilonから「Invalid handle request」が返されます。
正常に機能していない接続:
[nasadmin@xsbad10147 Contacts]$ fs_dhsm -c CIFS_GSGST -i
CIFS_GSGST:
state = enabled
offline attr = on
popup timeout = 0
backup = passthrough
read policy override = none
log file = on
max log size = 10MB
cid = 0
type = CIFS
secondary = \\xsbad10141-2.example.com\sfbad18502\
state = enabled
read policy override = none
write policy = full
local_server = SFBAD18502.EXAMPLE.COM
admin = example.com\s_bad1_fmadm
勝利 =
動作中の接続:
[nasadmin@xsbad10147 Contacts]$ fs_dhsm -c CIFS_T50_T3 -i
CIFS_GSGST:
state = enabled
offline attr = on
popup timeout = 0
backup = passthrough
read policy override = none
log file = on
max log size = 10MB
cid = 0
type = CIFS
secondary = \\xsbad10141-2.example.com\sfbad18502\
state = enabled
read policy override = none
write policy = full
local_server = SFBAD18502.EXAMPLE.COM
admin = example.com\s_bad1_fmadmin
の勝利=
Resolution
機能していないDHSM接続が削除されました。削除の発行時にエラーが発生した場合は、EMCサポートに問い合わせて、この記事を参照してください。
他の接続と一致する新しい管理者アカウントで接続が再作成されました。
データムーバーが再起動されました。
他の接続と一致する新しい管理者アカウントで接続が再作成されました。
データムーバーが再起動されました。
Additional Information
説明によると、ほとんどのCIFSサーバは、クライアントが常に最初の接続と同じユーザーを使用することを前提としています。(Isilonも同じことを想定する必要があります)
クライアント(この場合はData Mover)が、最初のユーザーがまだ接続している間に別のユーザーを使用しようとすると、CIFSサーバはアクセスを拒否します
クライアント(この場合はData Mover)が、最初のユーザーがまだ接続している間に別のユーザーを使用しようとすると、CIFSサーバはアクセスを拒否します
Affected Products
VNX1 SeriesProducts
Isilon, VNX1 Series, VNX2 SeriesArticle Properties
Article Number: 000056569
Article Type: Solution
Last Modified: 09 Oct 2024
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.