AppSync: Kan ikke legge til UNIX-klienten i AppSync Server ved hjelp av SUDO-bruker

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ny installasjon av vertsplugin for UNIX (AIX) i AppSync GUI.

Brukeren må bruke en SUDO UNIX-bruker og tillater ikke direkte root-pålogging.

Kan ikke legge til UNIX-klienten i AppSync Server ved hjelp av SUDO-brukeren.

AppSync GUI-dialogboks:

Brukeren har ikke nødvendige tillatelser for å kjøre implementeringen. Konfigurer brukeren i sudousers-filen på Unix-agent, eller oppgi de nødvendige tillatelsene.

 AppSync-serverlogg

service.xio.XIOServiceBean.discoverXMS(com.emc.archway.context.ExecutionContext,com.emc.archway.objectmodel.storage.xio.XIOManagementServer)
throws com.emc.archway.service.eventservice.exceptions.XIOManagementServerInvalidLoginException,com.emc.archway.service.eventservice.exceptions.XIOConnectionFailureException,com.emc.archway.errorMessages.XIORequestFailedException,com.emc.archway.errorMessages.XIORESTException

Acp..... OK.
aix/host.pyc..... MISLYKTES.
generisk/oracle.pyc..... MISLYKTES.
library.zip..... OK.
ADVARSEL: 2 av 4 filer har ikke samme meldingssammendrag.

INFO [Thread-189340 (HornetQ-client-global-threads-1147589765)]
[] Verification failed, deploying latest acp
ERROR [Thread-189340 (HornetQ-client-global-threads-1147589765)]
[] slibclean failed: ksh: slibclean: slibclean: 0403-006 Kjøretillatelse nektet.
WARN [Thread-189340 (HornetQ-client-global-threads-1147589765)]
[] Filen er allerede slettet: appsync.tar

Cause

Feil oppføringer i sudoers-filen og sftp-server kjører ikke som riktig bruker.

Resolution

  1. Bekreft følgende oppføringer i sudo-filen. Hvis operatøren ønsker å bruke sudo-brukeren 'appsync', bør oppføringen være:
Obligatoriske oppføringer i sudo-filen:
Defaults:appsync !requiretty
Defaults:appsync !env_reset
Defaults secure_path = /sbin:/bin:/usr/sbin:/usr/bin
appsync ALL = (root) NOPASSWD: /opt/emc/appsync/acp
  1. VIKTIG: Kontroller at SFTP-servertjenesten kjører.
Kjør følgende kommando for å kontrollere at SFTP fungerer som den skal
: sftp P-portnummer <><Bruker-Name@AppSync-server-IP-adresse>
 
EKSEMPEL GOD RESPONS:
#sftp P 22 asadmin@10.10.10.10
asadmin@10.10.10.10 passord:
koblet til 10.10.10.10
SFTP>

EKSEMPEL DÅRLIG RESPONS:
#sftp P 22 asadmin@10.10.10.10
asadmin@10.10.10.10 passord:
subsystem forespørsel mislyktes på kanal 0
tilkobling lukket
# 
  1. Slett alle filene på klientsiden i katalogen /opt/emc/appsync.
Opprett en mappe /appsync under /opt/emc, med lese-, skrive- og kjøretillatelser for SUDO-bruker appsync for installasjonsbanen /opt/emc/appsync/.
Dette betyr at katalogen må eies av "appsync" bruker.
  1. Du skal ha eierskapet og riktige skrivetillatelser i /opt/emc/appsync-katalogen.
For appsync-brukeren bør umask settes til 037 Bruk chmod -R 775 /opt/emc/appsync eller chmod g+s /opt/emc/appsync
  1. Kontroller tillatelsene til .rsp-filen på AppSync-klienten.
Som standard blir det alltid generert med root som eier (en standardoppførsel for SUDO-bruker), og vi må programmatisk endre eierskapet til SUDO-bruker.
  1. Bekreft at det ikke er noen brannmurer som blokkerer SFTP-operasjonen. Prøv å overføre en fil manuelt ved hjelp av sftp som appsync-bruker.

Additional Information

Se også: Referanse guide: AppSync-2.2.3-installasjons-og-konfigurasjon-veiledning
Push-installasjon for UNIX-vertsplugin med SUDO-bruker –> se AIX-delen.
I dette tilfellet er 'appsync' sudo-brukeren. Du bør legge til linjer under sudoer-filen:
Defaults:appsync !requiretty
Defaults:appsync !env_reset
defaults secure_path = /sbin:/bin:/usr/sbin:/usr/bin

appsync ALL = (root) NOPASSWD:/opt/emc/appsync/acp

Les også: KB-artikkel 483004: AppSync: Push-installasjon på Linux-vert mislykkes når den utføres av en SUDO-bruker

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000056621
Article Type: Solution
Last Modified: 18 Sep 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.