AppSync: Det går inte att lägga till UNIX-klienten till AppSync-servern med SUDO-användaren

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ny installation av UNIX (AIX) värdinsticksprogram i AppSync GUI.

Användaren måste använda en SUDO UNIX-användare och tillåter inte direkt rotinloggning.

Det går inte att lägga till UNIX-klienten till AppSync-servern med SUDO-användaren.

Dialogmeddelande i AppSync GUI:

Användaren har inte de behörigheter som krävs för att köra distributionen. Konfigurera användaren i sudousers-filen på unix-agenten eller ge de behörigheter som krävs.

 AppSync-serverlogg

service.xio.XIOServiceBean.discoverXMS(com.emc.archway.context.ExecutionContext,com.emc.archway.objectmodel.storage.xio.XIOManagementServer)
kastar com.emc.archway.service.eventservice.exceptions.XIOManagementServerInvalidLoginException,com.emc.archway.service.eventservice.exceptions.XIOConnectionFailureException,com.emc.archway.errorMessages.XIORequestFailedException,com.emc.archway.errorMessages.XIORESTException

Avs..... OKEJ.
aix/host.pyc..... MISSLYCKADES.
generisk/oracle.pyc..... MISSLYCKADES.
library.zip..... OKEJ.
VARNING: 2 av 4 filer har inte samma meddelandesammandrag.

INFO [Thread-189340 (HornetQ-client-global-threads-1147589765)]
[] Verifieringen misslyckades, distribution av det senaste ACP-FELET
[Thread-189340 (HornetQ-client-global-threads-1147589765)]
[] slibclean misslyckades: ksh: slibclean: 0403-006 Körningsbehörighet nekad.
WARN [Thread-189340 (HornetQ-client-global-threads-1147589765)]
[] Filen har redan tagits bort: appsync.tar

Cause

Felaktiga poster i sudoers-filen och sftp-server körs inte som rätt användare.

Resolution

  1. Bekräfta följande poster i sudo-filen. Om operatorn vill använda sudo-användaren "appsync" ska posten vara:
Obligatoriska poster i sudo-filen:
Standardvärden:appsync !requiretty
Standardvärden:appsync !env_reset
Standardvärden secure_path = /sbin:/bin:/usr/sbin:/usr/bin
appsync ALL = (root) NOPASSWD: /opt/emc/appsync/acp
  1. VIKTIGT! Kontrollera att SFTP-servertjänsten körs.
Kör följande kommando för att kontrollera att SFTP fungerar som det ska
: sftp P <Port-Number><User-Name@AppSync-Server-IPAddress>
 
EXEMPEL PÅ BRA SVAR:
#sftp P 22 asadmin@10.10.10.10
asadmin@10.10.10.10 lösenord:
ansluten till 10.10.10.10
sftp>

EXEMPEL DÅLIGT SVAR:
#sftp P 22 asadmin@10.10.10.10
asadmin@10.10.10.10 lösenord:
undersystembegäran misslyckades på kanal 0
Anslutning stängd
# 
  1. Ta bort alla filer på klientsidan i katalogen /opt/emc/appsync.
Skapa en mapp /appsync under /opt/emc, med läs-, skriv- och körningsbehörigheter för SUDO-användaren appsync för installationssökvägen /opt/emc/appsync/.
Det innebär att katalogen måste ägas av "appsync"-användaren.
  1. Ägarskap och rätt skrivbehörighet ska finnas i katalogen /opt/emc/appsync.
För appsync-användaren ska umask ställas in på 037 Use chmod -R 775 /opt/emc/appsync eller chmod g+s /opt/emc/appsync
  1. Kontrollera behörigheterna för .rsp-filen på AppSync-klienten.
Som standard genereras den alltid med root som ägare (ett standardbeteende för SUDO-användare) och vi måste programmatiskt ändra ägarskapet till SUDO-användare.
  1. Kontrollera att det inte finns några brandväggar som blockerar SFTP-åtgärden. Försök att överföra en fil manuellt med sftp som appsync-användare.

Additional Information

Se även: Referensmanual: AppSync-2.2.3-Installations-och-konfigurationsmanual
: Push-installation av UNIX-värdinsticksprogram med SUDO-användare –> se AIX-avsnittet.
I det här fallet är "appsync" sudo-användaren. Du bör lägga till rader under sudoer-filen:
Standardvärden:appsync !requiretty
Standardvärden:appsync !env_reset
Standardvärden secure_path = /sbin:/bin:/usr/sbin:/usr/bin

appsync ALL = (root)NOPASSWD:/opt/emc/appsync/acp

Se även: KB-artikel 483004: AppSync: Push-installation till Linux-värd misslyckas när den utförs av en SUDO-användare

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000056621
Article Type: Solution
Last Modified: 18 Sep 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.