AppSync: Nelze přidat klienta UNIX na server AppSync pomocí uživatele SUDO

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Instalace nového hostitelského zásuvného modulu UNIX (AIX) v grafickém uživatelském rozhraní AppSync.

Uživatel musí používat uživatele SUDO UNIX a neumožňuje přímé přihlášení root.

Nelze přidat klienta UNIX na AppSync Server pomocí uživatele SUDO.

Zpráva dialogového oknagrafického uživatelského rozhraní AppSync:

Uživatel nemá potřebná oprávnění ke spuštění nasazení. Nakonfigurujte uživatele v souboru sudousers v agentovi UNIX nebo zadejte požadovaná oprávnění.

 Protokol serveru AppSync

service.xio.XIOServiceBean.discoverXMS(com.emc.archway.context.ExecutionContext,com.emc.archway.objectmodel.storage.xio.XIOManagementServer)
vyvolá com.emc.archway.service.eventservice.exceptions.XIOManagementServerInvalidLoginException,com.emc.archway.service.eventservice.exceptions.XIOConnectionFailureException,com.emc.archway.errorMessages.XIORequestFailedException,com.emc.archway.errorMessages.XIORESTException

Akt..... OK.
aix/host.pyc..... NEÚSPĚŠNÝ.
generic/oracle.pyc..... NEÚSPĚŠNÝ.
library.zip..... OK.
VAROVÁNÍ: 2 ze 4 souborů nemají stejný výtah zprávy.

INFO [Thread-189340 (HornetQ-client-global-threads-1147589765)]
[] Ověření se nezdařilo, nasazení nejnovějšího acp
ERROR [Thread-189340 (HornetQ-client-global-threads-1147589765)]
[] slibclean failed: ksh: slibclean: 0403-006 Oprávnění ke spuštění bylo odepřeno.
WARN [Thread-189340 (HornetQ-client-global-threads-1147589765)]
[] Soubor je již odstraněn: appsync.tar

Cause

Nesprávné položky v souboru sudoers a server sftp neběží jako správný uživatel.

Resolution

  1. Potvrďte následující položky v souboru sudo. Pokud chce operátor použít uživatele sudo 'appsync', pak by položka měla být:
Povinné položky v souboru sudo:
Výchozí hodnoty:appsync !requiretty
Výchozí hodnoty:appsync !env_reset
Výchozí secure_path = /sbin:/bin:/usr/sbin:/usr/bin
appsync ALL = (root) NOPASSWD: /opt/emc/appsync/acp
  1. DŮLEŽITÉ: Ověřte, zda je spuštěna služba serveru SFTP.
Spuštěním následujícího příkazu zkontrolujte, zda SFTP funguje správně
: číslo><portu sftp P<, User-Name@AppSync-Server-IPAddress>
 
PŘÍKLAD DOBRÉ ODEZVY:
#sftp P 22 asadmin@10.10.10.10
asadmin@10.10.10.10 heslo:
připojeno k 10.10.10.10
sftp>

PŘÍKLAD ŠPATNÉ ODPOVĚDI:
#sftp P 22 asadmin@10.10.10.10
asadmin@10.10.10.10 heslo:
požadavek subsystému selhal na kanálu 0
spojení uzavřeno
# 
  1. Odstraňte všechny soubory na straně klienta v adresáři /opt/emc/appsync.
Vytvořte složku /appsync v umístění /opt/emc s oprávněními ke čtení, zápisu a spouštění pro uživatelskou appsync SUDO pro instalační cestu /opt/emc/appsync/.
To znamená, že adresář musí vlastnit uživatel "appsync".
  1. Vlastnictví a správná oprávnění k zápisu by měla být uvedena v adresáři /opt/emc/appsync.
Pro uživatele appsync by měl být parametr umask nastaven na hodnotu 037. Použijte příkaz "chmod -R 775 /opt/emc/appsync" nebo "chmod g+s" "/opt/emc/appsync".
  1. Zkontrolujte oprávnění souboru .rsp v klientovi AppSync.
Ve výchozím nastavení se vždy generuje s root jako vlastníkem (výchozí chování pro uživatele sudo) a musíme programově změnit vlastnictví na uživatele sudo.
  1. Ověřte, že operaci SFTP neblokují žádné brány firewall. Zkuste ručně přenést soubor pomocí sftp jako appsync uživatele.

Additional Information

Viz také: Referenční příručka: AppSync-2.2.3-Installation-and-Configuration-Guide
Hostitelský zásuvný modul UNIX Nabízená instalace s uživatelem SUDO –> viz část AIX.
V tomto případě 'appsync' je uživatel sudo. Do souboru sudoer byste měli přidat řádky:
Výchozí hodnoty:appsync !requiretty
Výchozí hodnoty:appsync !env_reset
Výchozí hodnoty secure_path = /sbin:/bin:/usr/sbin:/usr/bin

appsync ALL = (root)NOPASSWD:/opt/emc/appsync/acp

Viz také: Článek znalostní databáze 483004: AppSync: Nabízená instalace do linuxového hostitele selže, pokud ji provede uživatel SUDO

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000056621
Article Type: Solution
Last Modified: 18 Sep 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.