NetWorker: NMDA backup of Oracle control file failed

Summary: NMDA backup of Oracle control file fails with error.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker Oracle RMAN backup of database and archive logs are fine.
Backup of the control file failed with the following error:

Starting Control File and SPFILE Autobackup at 04-FEB-16
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of Control File and SPFILE Autobackup command on ORA_SBT_TAPE_1 channel at 02/04/2016 18:39:24
ORA-19506: failed to create sequential file, name="c-3162925413-20160204-02", parms=""
ORA-27027: sbtremove2 returned error
ORA-19511: Error received from media manager layer, error text:
   RPC receive operation failed; errno = Bad file number (2:14:9)

The RMAN backup script contains the following line:

CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE 'sbt_tape' TO '%F';

This also based Oracle shows all commands, the following listed:

CONFIGURE DEFAULT DEVICE TYPE TO 'SBT_TAPE';
CONFIGURE CONTROLFILE AUTOBACKUP ON;
CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE 'SBT_TAPE' TO '%F';
CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE DISK TO '%F'; # default

The same backup to disk works fine.

Index checked and started with fresh client index and same problem.
Issue observed only when "CONFIGURE CONTROLFILE AUTOBACKUP ON;"

Cause

The cause cannot be identified.

Resolution

In RMAN, set the AUTOBACKUP to off:

RMAN> CONFIGURE CONTROLFILE AUTOBACKUP off;

Add the following line to the RMAN script:


Backup current controlfile format 'CF_%d_%T_s%sp%pt%t';

Affected Products

NetWorker, NetWorker Module for Databases and Applications

Products

NetWorker Family
Article Properties
Article Number: 000056676
Article Type: Solution
Last Modified: 22 Jan 2026
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.