NetWorker: Obnovení jedné poštovní schránky z odstraněného archivu Selhání databáze
Summary: NetWorker: Obnovení jedné poštovní schránky z odstraněného archivu Selhání databáze
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Databáze archivu Exchange online se neodstraní.
Zákazník musí obnovit jednu poštovní schránku z odstraněné archivní databáze.
Spuštění RDB a obnovení databáze.
Použití příkazu Exchange PS "New-mailboxRestoreRequest" selhalo s chybou:
Mailbox"xxxxxxxxx" doesn't exist on database "YYYYY"
Cause
Zákazník použil k obnovení archivační poštovní schránky nesprávný příkaz
Resolution
Obnovení databáze znamená kopírování fyzických souborů ze záložního média (disku nebo pásky) do příslušných umístění souborů pro databázovou operaci. Obnovení je proces aktualizace databázových souborů obnovených ze zálohy se změnami provedenými v databázi od zálohování, obvykle pomocí souborů protokolu znovu. (Obnovené záložní soubory + změny = Obnovení).
Obnovení lze provést dvěma různými možnostmi:
Možnost 1:
Obnovení RDB bylo úspěšně dokončeno a data hlášena pomocí NW (z grafického uživatelského rozhraní NMM) nebo Exchange (pomocí následujícího příkazu) bez problémů:
[PS] C:\Windows\system32>Get-MailboxDatabase "YYYYYY" | Get-MailboxStatistics | ft displayname,totalitemsize| Výstupní soubor C:\YYYYYY_List.txt
.
Osobní archiv - user_example (123456) 1 759 GB (1 888 296 806 bajtů)
..
Abychom získali správný identifikátor GUID archivační poštovní schránky, spustili jsme následující příkaz Exchange:
[PS] C:\Windows\system32>Get-MailboxStatistics -database "YYYYYYY"|fl legacyDN,displayname,mailboxGUID,disconnectreason| Out-File C:\YYYYYY_GUID_List.txt
[PS] C:\Windows\system32>
LegacyDN : /O=CORP/OU=SKUPINA PRO SPRÁVU EXCHANGE (YGFODHOFHHFFOH)/CN=PŘÍJEMCI/CN=user_example (123456)123
DisplayName : Osobní archiv - user_example (123456)
MailboxGuid : aaaaa-bbbb-cccc-dddd-eeeeeeeeeeee
DisconnectReason :
+ FullyQualifiedErrorId : 65F1A251,Microsoft.Exchange.Management.RecipientTasks.RestoreMailbox
Poté spusťte následující příkaz pro obnovení a přidejte "baditemlimit", aby nedošlo k selhání kvůli vadným souborům:
[PS] C:\Windows\system32>Restore-Mailbox -RecoveryDatabase "YYYYYYY" -RecoveryMailbox aaaaa-bbbb-cccc-dddd-eeeeeeeeeeeeee -TargetFolder "Personal Archive - user_example (123456)" -Identity "user_example (123456)" -baditemlimit 200000
Na závěr budou hlášeny následující:
......
Typ přesunu : Obnovit
MoveStage : Hotový
Čas zahájení: mm/d/rrrr hh:mm:ss *M
Čas ukončení: mm/d/rrrr hh:mm:ss *M
Status Code :
0Stavová zpráva : Tato poštovní schránka v databázi pro obnovení byla obnovena do poštovní schránky cílového uživatele.
Soubor sestavy: E:\Microsoft Exchange\V14\Logging\MigrationLogs\restore-Mailboxyyyymmdd-hhmmss-1234567.xml
Možnost 2:
Chcete-li obnovit položky archivu z databáze pro obnovení, postupujte podle následujících příkazů:
Obnovte archivační poštovní schránku z databáze pro obnovení RRRRRR pomocí následujícího příkazu:
Get-Mailbox "user_example" | % { New-MailboxRestoreRequest -SourceDatabase YYYYYYY -SourceStoreMailbox "Osobní archiv - user_example (123456)" -TargetMailbox $_. Identity -TargetIsArchive }
Toto nejprve načte poštovní schránku uživatele a předá ji rutině New-MailboxRestoreRequest pomocí požadovaných parametrů.
Až ověříte, že je všechno obnovené, můžete dokončenou žádost o obnovení odebrat pomocí Get-MailboxRestoreRequest. Pokud například chcete odebrat všechny dokončené žádosti o obnovení ve spojení s rutinou Remove-RestoreRequest, použijte následující:
Get-MailboxRestoreRequest | kde { $_. Stav -eq Dokončeno } | Remove-MailboxRestoreRequest Confirm:$false
Obnovení lze provést dvěma různými možnostmi:
Možnost 1:
Obnovení RDB bylo úspěšně dokončeno a data hlášena pomocí NW (z grafického uživatelského rozhraní NMM) nebo Exchange (pomocí následujícího příkazu) bez problémů:
[PS] C:\Windows\system32>Get-MailboxDatabase "YYYYYY" | Get-MailboxStatistics | ft displayname,totalitemsize| Výstupní soubor C:\YYYYYY_List.txt
.
Osobní archiv - user_example (123456) 1 759 GB (1 888 296 806 bajtů)
..
Abychom získali správný identifikátor GUID archivační poštovní schránky, spustili jsme následující příkaz Exchange:
[PS] C:\Windows\system32>Get-MailboxStatistics -database "YYYYYYY"|fl legacyDN,displayname,mailboxGUID,disconnectreason| Out-File C:\YYYYYY_GUID_List.txt
[PS] C:\Windows\system32>
LegacyDN : /O=CORP/OU=SKUPINA PRO SPRÁVU EXCHANGE (YGFODHOFHHFFOH)/CN=PŘÍJEMCI/CN=user_example (123456)123
DisplayName : Osobní archiv - user_example (123456)
MailboxGuid : aaaaa-bbbb-cccc-dddd-eeeeeeeeeeee
DisconnectReason :
+ FullyQualifiedErrorId : 65F1A251,Microsoft.Exchange.Management.RecipientTasks.RestoreMailbox
Poté spusťte následující příkaz pro obnovení a přidejte "baditemlimit", aby nedošlo k selhání kvůli vadným souborům:
[PS] C:\Windows\system32>Restore-Mailbox -RecoveryDatabase "YYYYYYY" -RecoveryMailbox aaaaa-bbbb-cccc-dddd-eeeeeeeeeeeeee -TargetFolder "Personal Archive - user_example (123456)" -Identity "user_example (123456)" -baditemlimit 200000
Na závěr budou hlášeny následující:
......
Typ přesunu : Obnovit
MoveStage : Hotový
Čas zahájení: mm/d/rrrr hh:mm:ss *M
Čas ukončení: mm/d/rrrr hh:mm:ss *M
Status Code :
0Stavová zpráva : Tato poštovní schránka v databázi pro obnovení byla obnovena do poštovní schránky cílového uživatele.
Soubor sestavy: E:\Microsoft Exchange\V14\Logging\MigrationLogs\restore-Mailboxyyyymmdd-hhmmss-1234567.xml
Možnost 2:
Chcete-li obnovit položky archivu z databáze pro obnovení, postupujte podle následujících příkazů:
Obnovte archivační poštovní schránku z databáze pro obnovení RRRRRR pomocí následujícího příkazu:
Get-Mailbox "user_example" | % { New-MailboxRestoreRequest -SourceDatabase YYYYYYY -SourceStoreMailbox "Osobní archiv - user_example (123456)" -TargetMailbox $_. Identity -TargetIsArchive }
Toto nejprve načte poštovní schránku uživatele a předá ji rutině New-MailboxRestoreRequest pomocí požadovaných parametrů.
Až ověříte, že je všechno obnovené, můžete dokončenou žádost o obnovení odebrat pomocí Get-MailboxRestoreRequest. Pokud například chcete odebrat všechny dokončené žádosti o obnovení ve spojení s rutinou Remove-RestoreRequest, použijte následující:
Get-MailboxRestoreRequest | kde { $_. Stav -eq Dokončeno } | Remove-MailboxRestoreRequest Confirm:$false
Affected Products
NetWorkerArticle Properties
Article Number: 000056799
Article Type: Solution
Last Modified: 12 Mar 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.