NetWorker : La restauration d’une boîte aux lettres unique à partir d’une base de données d’archive supprimée a échoué
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Symptoms
Aucune modification
de la base de données d’archive Exchange Online n’est supprimée.
Le client doit restaurer une seule boîte aux lettres à partir de la base de données d’archive supprimée.
Exécutez la RDB et restaurez la base de données.
Échec de l’utilisation de la commande Exchange PS « New-mailboxRestoreRequest » avec l’erreur :
La boîte aux lettres « xxxxxxxxx » n’existe pas sur la base de données « AAAAA »
de la base de données d’archive Exchange Online n’est supprimée.
Le client doit restaurer une seule boîte aux lettres à partir de la base de données d’archive supprimée.
Exécutez la RDB et restaurez la base de données.
Échec de l’utilisation de la commande Exchange PS « New-mailboxRestoreRequest » avec l’erreur :
La boîte aux lettres « xxxxxxxxx » n’existe pas sur la base de données « AAAAA »
Cause
Le client a utilisé la mauvaise commande pour restaurer la boîte aux lettres d’archivage
Resolution
La restauration d’une base de données consiste à copier les fichiers physiques à partir d’un support de sauvegarde (disque ou bande) vers les emplacements de fichiers appropriés pour le fonctionnement de la base de données. La récupération est un processus de mise à jour des fichiers de base de données restaurés à partir de la sauvegarde avec des modifications apportées à la base de données depuis la sauvegarde, généralement à l’aide de fichiers journaux redo log. (Fichiers de sauvegarde restaurés + modifications = récupération).
La restauration peut être effectuée avec deux options différentes :
Option 1 :
La restauration de la RDB s’est terminée avec succès et les données ont été signalées à l’aide de NW (à partir de l’interface graphique NMM) ou d’Exchange (à l’aide de la commande suivante) sans problème :
[PS] C :\Windows\system32>Get-MailboxDatabase « YYYYYY » | Get-MailboxStatistics | FT DisplayName,TotalItemSize| Out-File C :\YYYYYY_List.txt
.
Archive personnelle - user_example (123456) 1 759 Go (1 888 296 806 octets)
..
Ainsi, afin d’obtenir le bon GUID de boîte aux lettres d’archivage, nous avons exécuté la commande Exchange suivante :
[PS] C :\Windows\system32>Get-MailboxStatistics -database « YYYYYYY"|fl legacyDN,displayname,mailboxGUID,disconnectreason| Out-File C :\YYYYYY_GUID_List.txt
[PS] C :\Windows\system32>
LegacyDN : /O=CORP/OU=EXCHANGE ADMINISTRATIVE GROUP (YGFODHOFHHFFOH)/CN=RECIPIENTS/CN=user_example (123456)123
DisplayName : Archivage personnel - user_example (123456)
MailboxGuid : aaaaaa-bbbb-cccc-dddd-eeeeeeeeee
DisconnectReason :
+ FullyQualifiedErrorId : 65F1A251,Microsoft.Exchange.Management.RecipientTasks.RestoreMailbox
Ensuite, exécutez la commande suivante pour restaurer et ajouter « baditemlimit » afin d’éviter l’échec dû à des fichiers défectueux :
[PS] C :\Windows\system32>Restore-Mailbox -RecoveryDatabase « YYYYYYY » -RecoveryMailbox aaaa-bbbb-cccc-dddd-eeeeee -TargetFolder « Personal Archive - user_example (123456) » -Identity « user_example (123456) » -baditemlimit 200000
À la fin, les éléments suivants seront signalés :
......
Type de déplacement : Restaurer
Scène de déplacement : Terminé
StartTime : mm/j/aaaa hh :mm :ss *M
EndTime : mm/j/aaaa hh :mm :ss *M
Code d’état :
0StatusMessage : Cette boîte aux lettres de la base de données de restauration a été restaurée dans la boîte aux lettres de l’utilisateur cible.
Fichier de rapport : E :\Microsoft Exchange\V14\Logging\MigrationLogs\restore-Mailboxyyyymmdd-hhmmss-1234567.xml
Option 2 :
Suivez les commandes ci-dessous pour restaurer les éléments d’archivage à partir d’une base de données de récupération :
Restaurez une boîte aux lettres d’archive à partir d’une base de données de restauration YYYYYY à l’aide de la commande suivante :
Get-Mailbox « user_example » | % { New-MailboxRestoreRequest -SourceDatabase YYYYYYY -SourceStoreMailbox « Personal Archive - user_example (123456) » -TargetMailbox $_. Identity -TargetIsArchive }
Cela récupère d’abord la boîte aux lettres de l’utilisateur et la transmet à la cmdlet New-MailboxRestoreRequest à l’aide des paramètres requis.
Une fois que vous avez vérifié que tout est restauré, vous pouvez supprimer la demande de restauration terminée à l’aide de Get-MailboxRestoreRequest. Par exemple, pour supprimer toutes les demandes de restauration terminées en conjonction avec la cmdlet Remove-RestoreRequest, utilisez ce qui suit :
Get-MailboxRestoreRequest | où { $_. Status -eq Completed } | Remove-MailboxRestoreRequest Confirm :$false
La restauration peut être effectuée avec deux options différentes :
Option 1 :
La restauration de la RDB s’est terminée avec succès et les données ont été signalées à l’aide de NW (à partir de l’interface graphique NMM) ou d’Exchange (à l’aide de la commande suivante) sans problème :
[PS] C :\Windows\system32>Get-MailboxDatabase « YYYYYY » | Get-MailboxStatistics | FT DisplayName,TotalItemSize| Out-File C :\YYYYYY_List.txt
.
Archive personnelle - user_example (123456) 1 759 Go (1 888 296 806 octets)
..
Ainsi, afin d’obtenir le bon GUID de boîte aux lettres d’archivage, nous avons exécuté la commande Exchange suivante :
[PS] C :\Windows\system32>Get-MailboxStatistics -database « YYYYYYY"|fl legacyDN,displayname,mailboxGUID,disconnectreason| Out-File C :\YYYYYY_GUID_List.txt
[PS] C :\Windows\system32>
LegacyDN : /O=CORP/OU=EXCHANGE ADMINISTRATIVE GROUP (YGFODHOFHHFFOH)/CN=RECIPIENTS/CN=user_example (123456)123
DisplayName : Archivage personnel - user_example (123456)
MailboxGuid : aaaaaa-bbbb-cccc-dddd-eeeeeeeeee
DisconnectReason :
+ FullyQualifiedErrorId : 65F1A251,Microsoft.Exchange.Management.RecipientTasks.RestoreMailbox
Ensuite, exécutez la commande suivante pour restaurer et ajouter « baditemlimit » afin d’éviter l’échec dû à des fichiers défectueux :
[PS] C :\Windows\system32>Restore-Mailbox -RecoveryDatabase « YYYYYYY » -RecoveryMailbox aaaa-bbbb-cccc-dddd-eeeeee -TargetFolder « Personal Archive - user_example (123456) » -Identity « user_example (123456) » -baditemlimit 200000
À la fin, les éléments suivants seront signalés :
......
Type de déplacement : Restaurer
Scène de déplacement : Terminé
StartTime : mm/j/aaaa hh :mm :ss *M
EndTime : mm/j/aaaa hh :mm :ss *M
Code d’état :
0StatusMessage : Cette boîte aux lettres de la base de données de restauration a été restaurée dans la boîte aux lettres de l’utilisateur cible.
Fichier de rapport : E :\Microsoft Exchange\V14\Logging\MigrationLogs\restore-Mailboxyyyymmdd-hhmmss-1234567.xml
Option 2 :
Suivez les commandes ci-dessous pour restaurer les éléments d’archivage à partir d’une base de données de récupération :
Restaurez une boîte aux lettres d’archive à partir d’une base de données de restauration YYYYYY à l’aide de la commande suivante :
Get-Mailbox « user_example » | % { New-MailboxRestoreRequest -SourceDatabase YYYYYYY -SourceStoreMailbox « Personal Archive - user_example (123456) » -TargetMailbox $_. Identity -TargetIsArchive }
Cela récupère d’abord la boîte aux lettres de l’utilisateur et la transmet à la cmdlet New-MailboxRestoreRequest à l’aide des paramètres requis.
Une fois que vous avez vérifié que tout est restauré, vous pouvez supprimer la demande de restauration terminée à l’aide de Get-MailboxRestoreRequest. Par exemple, pour supprimer toutes les demandes de restauration terminées en conjonction avec la cmdlet Remove-RestoreRequest, utilisez ce qui suit :
Get-MailboxRestoreRequest | où { $_. Status -eq Completed } | Remove-MailboxRestoreRequest Confirm :$false
Affected Products
NetWorkerArticle Properties
Article Number: 000056799
Article Type: Solution
Last Modified: 12 Mar 2025
Version: 4
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