NetWorker: Ripristino di una singola casella di posta dall'archivio eliminato Database non riuscito

Summary: NetWorker: Ripristino di una singola casella di posta dall'archivio eliminato Database non riuscito

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Nessuna modifica

Il database di archivio di Exchange Online viene eliminato.
Il cliente deve ripristinare una singola casella di posta dal database di archivio eliminato.
Esecuzione di RDB e ripristino del DB.
L'utilizzo del comando "New-mailboxRestoreRequest" di Exchange PS non è riuscito con errore:

Mailbox"xxxxxxxxx" non esiste nel database "YYYYY"

Cause

Il cliente ha utilizzato il comando errato per ripristinare la casella di posta di archiviazione

Resolution

Il ripristino di un database consiste nel copiare i file fisici da un supporto di backup (disco o nastro) nei percorsi di file appropriati per il funzionamento del database. Il ripristino è un processo di aggiornamento dei file di database ripristinati dal backup con le modifiche apportate al database dopo il backup, in genere tramite file di log di ripristino. (File di backup ripristinati + modifiche = Ripristino).

Il ripristino può essere eseguito con due diverse opzioni:

Opzione 1:

il ripristino dell RDB è stato completato correttamente e i dati sono stati segnalati utilizzando NW (dalla GUI NMM) o Exchange (utilizzando il seguente comando) senza problemi:

[PS] C:\Windows\system32>Get-MailboxDatabase "YYYYYY" | Get-MailboxStatistics | FT DisplayName,TotalItemSize| Out-File C:\YYYYYY_List.txt

.
Archivio personale - user_example (123456) 1,759 GB (1,888,296,806 byte)                            
..

Pertanto, per ottenere il GUID corretto della casella di posta di archiviazione, abbiamo eseguito il seguente comando di Exchange:
 
[PS] C:\Windows\system32>Get-MailboxStatistics -database "YYYYYY"|fl legacyDN,displayname,mailboxGUID,disconnectreason| Out-File C:\YYYYYY_GUID_List.txt
[PS] C:\Windows\system32>
 
LegacyDN : /O=CORP/OU=GRUPPO AMMINISTRATIVO EXCHANGE (YGFODHOFHHFFOH)/CN=RECIPIENTS/CN=user_example (123456)123
DisplayName : Archivio Personale - user_example (123456)
Casella di postaGuid : aaaaaaaaa-bbbb-cccc-dddd-eeeeeeeeeeee
DisconnectReason:
 
    + FullyQualifiedErrorId: 65F1A251,Microsoft.Exchange.Management.RecipientTasks.RestoreMailbox

Quindi, eseguire il seguente comando per ripristinare e aggiungere "baditemlimit" per evitare l'errore dovuto a file danneggiati:
 
[PS] C:\Windows\system32>Restore-Mailbox -RecoveryDatabase "YYYYYYY" -RecoveryMailbox aaaaaaaa-bbbb-cccc-dddd-eeeeeeeeee -TargetFolder "Personal Archive - user_example (123456)" -Identity "user_example (123456)" -baditemlimit 200000


Al termine, verranno riportati:

......
Tipo di mossa : Restaurare
MoveStage : Finito
Ora di inizio : mm/g/aaaa hh:mm:ss *M
Ora di fine: gg/mm/aaaa hh:mm:ss *M
Codice di stato:
0StatusMessage : Questa casella di posta nel database di ripristino è stata ripristinata nella casella di posta dell'utente di destinazione.
File di report: E:\Microsoft Exchange\V14\Logging\MigrationLogs\restore-Mailboxyyyymmdd-hhmmss-1234567.xml


Opzione 2:

Seguire i comandi seguenti per ripristinare gli elementi archiviati da un database di ripristino:
 
Ripristinare una casella di posta archiviata da un database di ripristino YYYYYY utilizzando il seguente comando:
 
Get-Mailbox "user_example" | % { New-MailboxRestoreRequest -SourceDatabase YYYYYYY -SourceStoreMailbox "Archivio personale - user_example (123456)" -TargetMailbox $_. Identity -TargetIsArchive }
 
In questo modo verrà recuperata prima la cassetta postale dell'utente e verrà passata al cmdlet New-MailboxRestoreRequest utilizzando i parametri richiesti.
 
Dopo aver verificato che tutto sia stato ripristinato, è possibile rimuovere la richiesta di ripristino completata utilizzando Get-MailboxRestoreRequest. Ad esempio, per rimuovere tutte le richieste di ripristino completate insieme al cmdlet Remove-RestoreRequest, utilizzare quanto segue:
 
Get-MailboxRestoreRequest | dove { $_. Stato -eq Completato } | Remove-MailboxRestoreRequest Confirm:$false 

Affected Products

NetWorker
Article Properties
Article Number: 000056799
Article Type: Solution
Last Modified: 12 Mar 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.