SourceOne E-Mail-Management – Indexsätze befinden sich im Status "Unperformed Transaction".
Summary: SourceOne E-Mail-Management – Indexsätze befinden sich im Status "Unperformed Transaction".
Symptoms
Indexsätze in der SourceOne Email Management Console haben den Status Nicht durchgeführte Transaktion .
Das folgende Ereignis wird in den EMC Ereignisprotokollen aufgezeichnet:Log Name: EMCSource: EMC SourceOneDate: <Date\Time>Event ID: 11080Task Category: ExAsIdxObjLevel: WarningKeywords: ClassicUser: N/AComputer: <SERVER>Description:[ArchiveFolder_YearMonth_IndexSet] Failed to process transaction <SHARE TO XVLTS\UPDS> (0x86042B48) [ExAsIdxObj.exe, IndexThread.cpp(1294).IndexThread::IdxCmdPollByType]
Bei jeder Suche nach diesen Indexsätzen, entweder über SourceOne Web Search oder Discovery Manager, wird ein Fehler ähnlich dem folgenden protokolliert:
Unperformed transactions in index. (Occurred 1 time(s))
Error Detail: 21:(ArchiveFolder_YearMonth_IndexSet) (1 / 1) Search results may be incomplete, <\\ServerShare\ArchiveFolder\YearMonth\IndexSet> has unperformed transaction issues. (0x86042D22) (0x86044109)
Cause
Eine nicht durchgeführte Transaktion tritt auf, wenn der ExAsIdxobj.exe\ExAsElasticIDxObj.exe-Prozess nach mehreren Versuchen nicht in der Lage ist, eine Nachricht zu verarbeiten, auf die in der Transaktionsdatei im Indexordner DropDir verwiesen wird. Die problematische Transaktionsdatei wird aus dem Index DropDir in den Ordner DropDir\Intermediary verschoben, und der zugehörige Indexsatz für die betreffende Transaktion wird in der SourceOne Email Management Console in den Status "Nicht durchgeführte Transaktion" versetzt.
Resolution
Erneutes Verarbeiten der Transaktionsdatei
1. Identifizieren Sie die zugehörigen Transaktionsdateien im Ordner DropDir\Intermediary für den Indexsatz, der als Unperformed Transaction markiert ist. Der Dateiname hat das folgende Format:
ArchiveFolder_YearMonth_IndexSet.xvlts oder ArchiveFolder_YearMonth_IndexSet.upds
2. Verschieben Sie die Datei aus dem Zwischenordner zurück in den DropDir-Ordner, und lassen Sie sie erneut verarbeiten.
3. Wenn die Transaktion erfolgreich verarbeitet wird, wird der zugeordnete Indexsatz als Verfügbar markiert, und die Transaktionsdatei wird aus dem DropDir entfernt.
4. Wenn die Transaktionsdateien erneut in den Zwischenordner verschoben werden, versuchen Sie, den Indexsatz neu zu erstellen.
HINWEIS: Es ist wichtig, dass die Transaktion NICHT aus dem Zwischenordner in das DropDir kopiert wird. Die Datei muss verschoben werden.
Erneutes Erstellen des Indexsatzes
1. Wenn die erneute Verarbeitung der Transaktionsdatei erneut in den Ordner DropDir\Intermediary verschoben wird, versuchen Sie, den betreffenden Indexsatz neu zu erstellen.
2. Sobald die Neuerstellung abgeschlossen ist und der Indexsatz im Status Available gekennzeichnet ist, löschen Sie die zugehörige Transaktionsdatei aus dem Ordner DropDir\Intermediary.
ANMERKUNG: Wenn sowohl die erneute Verarbeitung der Transaktionsdatei als auch die Neuerstellung des Indexsatzes das Problem nicht beheben, wird empfohlen, ein Upgrade auf die neueste Version von SourceOne Email Management durchzuführen. Sobald das Upgrade abgeschlossen ist, sollten dieselben Lösungsschritte wiederholt werden.