SourceOne Email Management - Les jeux d’index sont à l’état « Transaction non exécutée ».

Summary: SourceOne Email Management - Les jeux d’index sont à l’état « Transaction non exécutée ».

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Symptoms



L’état des ensembles d’index dans la console de gestion des e-mails SourceOne est Transaction non effectuée.

L’événement suivant est consigné dans les journaux d’événements EMC :

Log Name:      EMC
Source:        EMC SourceOne
Date:          <Date\Time>
Event ID:      11080
Task Category: ExAsIdxObj
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      <SERVER>
Description:
[ArchiveFolder_YearMonth_IndexSet] Failed to process transaction <SHARE TO XVLTS\UPDS> (0x86042B48) [ExAsIdxObj.exe, IndexThread.cpp(1294).IndexThread::IdxCmdPollByType] 

Toute recherche sur ces jeux d’index, que ce soit via SourceOne Web Search ou Discovery Manager, consigne une erreur similaire à ce qui suit :

Unperformed transactions in index. (Occurred 1 time(s))               

Error Detail: 21:(ArchiveFolder_YearMonth_IndexSet) (1 / 1) Search results may be incomplete, <\\ServerShare\ArchiveFolder\YearMonth\IndexSet> has unperformed transaction issues. (0x86042D22) (0x86044109)

Cause

Les tâches d’indexation dans Index\DropDir sont appelées Transactions. Ces tâches peuvent inclure des transactions d’indexation de nouveaux messages (.xvlts\.txvlts) et de mises à jour du propriétaire (.upds\.tupds), lorsque les transactions contiennent des références à des messages individuels qui doivent être indexés ou dont la propriété doit être mise à jour.

Une transaction non exécutée se produit lorsque, après plusieurs tentatives, le processus ExAsIdxobj.exe\ExAsElasticIDxObj.exe ne parvient pas à traiter un message référencé dans le fichier de transaction situé dans le dossier DropDir d’index. Le fichier de transaction problématique est déplacé de l’index DropDir vers le dossier DropDir\Intermediary et l’ensemble d’index associé pour la transaction en question est placé à l’état Transaction non exécutée dans la console de gestion des e-mails SourceOne.

Resolution

Pour résoudre le problème, procédez comme suit.

Retraiter le fichier

de transaction1.    Identifiez les fichiers de transaction associés dans le dossier DropDir\Intermediary pour le jeu d’index marqué comme Transaction non exécutée. Le nom de fichier sera au format de dénomination suivant : 

ArchiveFolder_YearMonth_IndexSet.xvlts ou ArchiveFolder_YearMonth_IndexSet.upds

2.    Déplacez le fichier du dossier intermédiaire vers le dossier DropDir et laissez-le traiter à nouveau.

3.    Si la transaction est traitée avec succès, l’ensemble d’index associé sera marqué comme Disponible et le fichier de transaction sera supprimé du DropDir.

4.    Si les fichiers de transaction sont à nouveau déplacés vers le dossier Intermédiaire, essayez de reconstruire le jeu d’index.

                Remarque : Il est important que la transaction ne soit PAS copiée du dossier Intermediary vers le DropDir. Le fichier doit être déplacé.

Reconstruire le jeu

d’index1.    Si le retraitement du fichier de transaction est à nouveau déplacé dans le dossier DropDir\Intermediary, essayez de reconstruire l’ensemble d’index en question. 

2.    Une fois la reconstruction terminée et l’ensemble d’index marqué à l’état Disponible, supprimez le fichier de transaction associé du dossier RépDrop\Intermédiaire.

NOTE: Si le retraitement du fichier de transaction et la reconstruction du jeu d’index ne résolvent pas le problème, il est recommandé d’effectuer une mise à niveau vers la dernière version de SourceOne Email Management. Une fois la mise à niveau terminée, les mêmes étapes de résolution doivent être répétées.

Affected Products

SourceOne Email Management

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000057004
Article Type: Solution
Last Modified: 02 Jun 2025
Version:  6
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