Gestione della posta elettronica di SourceOne: i set di indici sono in uno stato di "transazione non eseguita".
Summary: Gestione della posta elettronica di SourceOne: i set di indici sono in uno stato di "transazione non eseguita".
Symptoms
I set di indici nella console di gestione della posta elettronica di SourceOne hanno uno stato di transazione non eseguita .
Il seguente evento verrà registrato nei registri eventi EMC:Log Name: EMCSource: EMC SourceOneDate: <Date\Time>Event ID: 11080Task Category: ExAsIdxObjLevel: WarningKeywords: ClassicUser: N/AComputer: <SERVER>Description:[ArchiveFolder_YearMonth_IndexSet] Failed to process transaction <SHARE TO XVLTS\UPDS> (0x86042B48) [ExAsIdxObj.exe, IndexThread.cpp(1294).IndexThread::IdxCmdPollByType]
Qualsiasi ricerca su questi set di indici, tramite SourceOne Web Search o Discovery Manager, registrerà un errore simile al seguente:
Unperformed transactions in index. (Occurred 1 time(s))
Error Detail: 21:(ArchiveFolder_YearMonth_IndexSet) (1 / 1) Search results may be incomplete, <\\ServerShare\ArchiveFolder\YearMonth\IndexSet> has unperformed transaction issues. (0x86042D22) (0x86044109)
Cause
Una transazione non eseguita si verifica quando, dopo diversi tentativi, il processo ExAsIdxobj.exe\ExAsElasticIDxObj.exe non è in grado di elaborare un messaggio a cui si fa riferimento nel file della transazione che si trova nella cartella DropDir dell'indice. Il file della transazione problematico viene spostato dall'indice DropDir alla cartella DropDir\Intermediary e l'indice associato per la transazione in questione viene inserito in uno stato Transazione non eseguita nella console di gestione della posta elettronica di SourceOne.
Resolution
Rielaborare il file
della transazione1. Identificare i file di transazione associati nella cartella DropDir\Intermediary per l'insieme di indici contrassegnato come Transazione non eseguita . Il nome del file sarà nel seguente formato di denominazione:
ArchiveFolder_YearMonth_IndexSet.xvlts o ArchiveFolder_YearMonth_IndexSet.upds
2. Spostare nuovamente il file dalla cartella intermedia alla cartella DropDir e attenderne la nuova elaborazione.
3. Se la transazione viene elaborata correttamente, il set di indici associato verrà contrassegnato come Disponibile e il file della transazione verrà rimosso dalla DropDir.
4. Se i file delle transazioni vengono nuovamente spostati nella cartella Intermediary, tentare di ricostruire il set di indici.
NOTA: È importante che la transazione NON venga copiata dalla cartella Intermediary alla DropDir. Il file deve essere spostato.
Ricostruire il set
di indici1. Se la rielaborazione del file di transazione viene nuovamente spostata nella cartella DropDir\Intermediary, tentare di ricostruire il set di indici in questione.
2. Una volta completata la ricostruzione e contrassegnato il set di indici in stato Available, eliminare il file della transazione associato dalla cartella DropDir\Intermediary.
NOTA: Se la rielaborazione del file della transazione e la ricostruzione del set di indici non risolvono il problema, si consiglia di eseguire l'aggiornamento alla versione più recente di SourceOne Email Management. Una volta completato l'aggiornamento, ripetere gli stessi passaggi di risoluzione.