AppSync: AppSync GUI viser ikke loginskærmen og præsenterer: "Fejl 404 ikke fundet"

Summary: Brugeren ser skærmbilledet "Fejl 404 ikke fundet", når han forsøger at logge ind på Appsync GUI.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Brugeren ser skærmbilledet "Fejl 404 ikke fundet", når han forsøger at logge ind på Appsync GUI.

Følgende fejl kan forekomme i server.log filen:

04-04-2017 12:03:37.854 INFO [DeploymentScanner-threads - 1] [org.jboss.as.server.deployment.scanner] [] [] WFLYDS0019: Implementering apollo.ear blev tidligere implementeret af denne scanner, men er blevet fjernet fra serverimplementeringslisten af et andet administrationsværktøj. Markørfil E:\EMC\AppSync\jboss\.\standalone\.. \applications\apollo.ear.undeployed tilføjes for at registrere dette.

04-04-2017 12:03:17.575 INFO [Tråd-2] [org.jboss.as.server] [] [] WFLYSRV0220: Der er anmodet om nedlukning af serveren.
04-04-2017 12:05:16.007 INFO [MSC-servicetråd 1-7] [org.wildfly.extension.undertow] [] [] WFLYUT0012: Startede serverens standardserver.
04-04-2017 12:05:18.041 INFO [MSC-servicetråd 1-3] [org.jboss.ws.common.management] [] [] JBWS022052: Start af JBoss Web Services - Stack CXF Server 5.0.0.Final
 
04-04-2017 12:12:26.097 INFO [Tråd-2] [org.jboss.as.server] [] [] WFLYSRV0220:
04-04-2017 12:12:29.320 INFO [MSC-servicetråd 1-6] [org.wildfly.extension.undertow] [] [] WFLYUT0012: Startede serverens standardserver.
04-04-2017 12:12:29.711 INFO [MSC-servicetråd 1-8] [org.jboss.ws.common.management] [] [] JBWS022052: Start af JBoss Web Services - Stack CXF Server 5.0.0.Final
 
04-04-2017 12:15:29.212 INFO [Tråd-2] [org.jboss.as.server] [] [] WFLYSRV0220: Der er anmodet om nedlukning af serveren.
04-04-2017 12:15:35.364 INFO [MSC-servicetråd 1-1] [org.wildfly.extension.undertow] [] [] WFLYUT0012: Startede serverens standardserver.
04-04-2017 12:15:35.745 INFO [MSC-servicetråd 1-8] [org.jboss.ws.common.management] [] [] JBWS022052: Start af JBoss Web Services - Stack CXF Server 5.0.0.Final
 
04-04-2017 12:40:30.529 INFO [Tråd-2] [org.jboss.as.server] [] [] WFLYSRV0220: Der er anmodet om nedlukning af serveren.
04-04-2017 12:43:36.972 INFO [MSC-servicetråd 1-2] [org.wildfly.extension.undertow] [] [] WFLYUT0012: Startede serverens standardserver.
04-04-2017 12:43:37.354 INFO [MSC-servicetråd 1-7] [org.jboss.ws.common.management] [] [] JBWS022052: Start af JBoss Web Services – Stack CXF Server 5.0.0.Final

 

Cause

Dette kan ses, hvis Appsync Server-tjenesterne startes og stoppes hurtigt efter hinanden. Der er en række filer, f.eks. E:\EMC\AppSync\jboss\.\standalone\.. \applications\apollo.ear, som implementeres af AppSync-serveren under opstart. Hvis tjenesten stoppes, før disse filer er fuldt implementeret, kan AppSync-serveren begynde at kaste denne fejl.

Når vi kontrollerer placeringen C: \ EMC \ AppSync \ jboss \ applikationer, skal vi se følgende 6 filer i et sundt system: 

  • Apollo.øre
  • apollo.ear.deployed
  • buevej-øre.øre
  • archway-ear.ear.deployed
  • remotex.rar
  • remotex.rar. indsat


Når vi kontrollerer et system, der viser fejlen "Fejl 404 ikke fundet", skal vi finde nogle af disse filer markeret som ikke-implementeret, f.eks. "apollo.ear.undeployed ".

Resolution

Løsning:
For at løse dette problem er vi nødt til at få Appsync Server-tjenesten til at implementere . EAR-filer. Følg proceduren beskrevet nedenfor for at opnå dette. 
Når vi finder ikke-implementerede filer i mappen C: \ EMC \ AppSync \ jboss \ applications, skal du udføre nedenstående trin for at løse:

  1. Stop alle tjenester.
  2. Tag backup af C:\EMC\AppSync\jboss\applications.
  3. Omdøb Apollo.ear.undeployed til Apollo.ear.dodeploy.
  4. Udfør de samme trin som trin 3, hvis andre EAR-filer også vises som ikke-implementeret.
  5. Start tjenesterne.
  6. Kontrollér status for . EAR-filer igen på placeringen C:\EMC\AppSync\jboss\applications.
i. Apollo.øre
II. Apollo.Ear.Deployed
III. buegang-øre.øre
iv.archway-ear.ear.deployed
v.remotex.rar
vi.remotex.rar. indsat
  1. Prøv at logge ind på appsync GUI efter 5 minutter, og du bør kunne logge ind.

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000057111
Article Type: Solution
Last Modified: 18 Sep 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.