AppSync: Die AppSync-GUI zeigt den Anmeldebildschirm nicht an und zeigt Folgendes an: "Fehler 404 nicht gefunden"
Summary: Dem Nutzer wird der Bildschirm "Error 404 not found" angezeigt, wenn er versucht, sich bei der AppSync-GUI anzumelden.
Symptoms
Dem Nutzer wird der Bildschirm "Error 404 not found" angezeigt, wenn er versucht, sich bei der AppSync-GUI anzumelden.
In der server.log Datei werden möglicherweise die folgenden Fehler angezeigt:
04-04-2017 12:03:37.854 INFO [DeploymentScanner-threads - 1] [org.jboss.as.server.deployment.scanner] [] [] WFLYDS0019: Bereitstellung apollo.ear wurde zuvor von diesem Scanner bereitgestellt, wurde jedoch von einem anderen Verwaltungstool aus der Serverbereitstellungsliste entfernt. Markerdatei E:\EMC\AppSync\jboss\.\standalone\.. \Applications\apollo.ear.undeployed wird hinzugefügt, um diese Tatsache aufzuzeichnen.
04-04-2017 12:03:17.575 INFO [Thread-2] [org.jboss.as.server] [] [] WFLYSRV0220: Das Herunterfahren des Servers wurde angefordert.
04-04-2017 12:05:16.007 INFO [MSC Service Thread 1-7] [org.wildfly.extension.undertow] [] [] WFLYUT0012: Server default-server gestartet.
04-04-2017 12:05:18.041 INFO [MSC-Dienst Thread 1-3] [org.jboss.ws.common.management] [] [] JBWS022052: Starten von JBoss Web Services - Stack CXF Server 5.0.0.Final
04-04-2017 12:12:26.097 INFO [Thread-2] [org.jboss.as.server] [] [] WFLYSRV0220:
04-04-2017 12:12:29.320 INFO [MSC-Service-Thread 1-6] [org.wildfly.extension.undertow] [] [] WFLYUT0012: Server default-server gestartet.
04-04-2017 12:12:29.711 INFO [MSC Service Thread 1-8] [org.jboss.ws.common.management] [] [] JBWS022052: Starten von JBoss Web Services - Stack CXF Server 5.0.0.Final
04-04-2017 12:15:29.212 INFO [Thread-2] [org.jboss.as.server] [] WFLYSRV0220: Das Herunterfahren des Servers wurde angefordert.
04-04-2017 12:15:35.364 INFO [MSC Service Thread 1-1] [org.wildfly.extension.undertow] [] [] WFLYUT0012: Server default-server gestartet.
04-04-2017 12:15:35.745 INFO [MSC Service Thread 1-8] [org.jboss.ws.common.management] [] [] JBWS022052: Starten von JBoss Web Services - Stack CXF Server 5.0.0.Final
04-04-2017 12:40:30.529 INFO [Thread-2] [org.jboss.as.server] [] [] WFLYSRV0220: Das Herunterfahren des Servers wurde angefordert.
04-04-2017 12:43:36.972 INFO [MSC Service Thread 1-2] [org.wildfly.extension.undertow] [] [] WFLYUT0012: Server default-server gestartet.
04-04-2017 12:43:37.354 INFO [MSC-Dienst Thread 1-7] [org.jboss.ws.common.management] [] [] JBWS022052: Starten von JBoss Web Services – Stack CXF Server 5.0.0.Final
Cause
Dies kann auftreten, wenn die AppSync Server-Services in schneller Abfolge gestartet und beendet werden. Es gibt eine Reihe von Dateien, z. B. E:\EMC\AppSync\jboss\.\standalone\.. \applications\apollo.ear, die vom AppSync-Server während des Startvorgangs bereitgestellt werden. Wenn der Service beendet wird, bevor diese Dateien vollständig bereitgestellt wurden, beginnt der AppSync-Server möglicherweise, diesen Fehler auszugeben.
Wenn wir den Speicherort C:\EMC\AppSync\jboss\applications überprüfen, sollten wir die folgenden 6 Dateien in einem fehlerfreien System sehen:
- Apollo.ear
- apollo.ear.deployed
- bogen-ohr.ear
- bogen-ohr.ear.deployed
- remotex.rar
- remotex.rar. bereitgestellt
Wenn wir auf einem System nach dem Fehler "Error 404 not found" suchen, sollten wir einige dieser Dateien finden, die als nicht bereitgestellt markiert sind, z. B. "apollo.ear.undeployed".
Resolution
Problemumgehung:
Um dieses Problem zu beheben, müssen wir den AppSync Server-Service aufrufen, um die . EAR-Dateien. Befolgen Sie dazu das unten beschriebene Verfahren.
Wenn wir nicht bereitgestellte Dateien im Ordner C:\EMC\AppSync\jboss\applications finden, führen Sie die folgenden Schritte aus, um Folgendes zu beheben:
- Beenden Sie alle Services.
- Erstellen Sie ein Backup von C:\EMC\AppSync\jboss\applications.
- Benennen Sie Apollo.ear.undeployed in Apollo.ear.dodeploy um.
- Führen Sie die gleichen Schritte wie in Schritt 3 aus, falls andere EAR-Dateien ebenfalls als nicht bereitgestellt angezeigt werden.
- Starten Sie die Services.
- Überprüfen Sie den Status für . EAR-Dateien erneut am Speicherort C:\EMC\AppSync\jboss\applications.
- Versuchen Sie nach 5 Minuten, sich bei der AppSync-GUI anzumelden. Sie sollten sich dann wieder anmelden können.