AppSync. Графический интерфейс пользователя AppSync не отображает экран входа в систему и отображает: «Ошибка 404 не найдена»

Summary: При попытке входа в графический интерфейс пользователя Appsync отображается экран «Ошибка 404 не найдена».

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



При попытке входа в графический интерфейс пользователя Appsync отображается экран «Ошибка 404 не найдена».

В server.log файле могут отображаться следующие ошибки:

04-04-2017 12:03:37.854 INFO [DeploymentScanner-threads - 1] [org.jboss.as.server.deployment.scanner] [] WFLYDS0019: Развертывание Apollo.ear ранее был развернут этим сканером, но был удален из списка развертывания сервера другим инструментом управления. Файл маркера E:\EMC\AppSync\jboss\.\standalone\.. \Applications\Apollo.ear.undeployed, чтобы зафиксировать этот факт.

04-04-2017 12:03:17.575 INFO [Поток-2] [org.jboss.as.server] [] [] WFLYSRV0220: Был запрошен запрос на завершение работы сервера.
04-04-2017 12:05:16.007 INFO [MSC service thread 1-7] [org.wildfly.extension.undertow] [] [] WFLYUT0012: Запущен сервер default-server.
04-04-2017 12:05:18.041 INFO [MSC service thread 1-3] [org.jboss.ws.common.management] [] [] JBWS022052: Запуск JBoss Web Services - Stack CXF Server 5.0.0.Final
 
04.04.2017 12:12:26.097 INFO [Поток-2] [org.jboss.as.server] [] [] WFLYSRV0220:
04-04-2017 12:12:29.320 INFO [MSC Service Thread 1-6] [org.wildfly.extension.undertow] [] [] WFLYUT0012: Запущен сервер default-server.
04-04-2017 12:12:29.711 INFO [MSC service thread 1–8] [org.jboss.ws.common.management] [] [] JBWS022052: Запуск JBoss Web Services - Stack CXF Server 5.0.0.Final
 
04-04-2017 12:15:29.212 INFO [Thread-2] [org.jboss.as.server] [] [] WFLYSRV0220: Был запрошен запрос на завершение работы сервера.
04-04-2017 12:15:35.364 INFO [MSC service thread 1-1] [org.wildfly.extension.undertow] [] [] WFLYUT0012: Запущен сервер default-server.
04-04-2017 12:15:35.745 INFO [MSC service thread 1-8] [org.jboss.ws.common.management] [] [] JBWS022052: Запуск JBoss Web Services — Stack CXF Server 5.0.0.Final
 
04.04.2017 12:40:30.529 INFO [Поток-2] [org.jboss.as.server] [] WFLYSRV0220: Был запрошен запрос на завершение работы сервера.
04-04-2017 12:43:36.972 INFO [MSC service thread 1-2] [org.wildfly.extension.undertow] [] [] WFLYUT0012: Запущен сервер default-server.
04-04-2017 12:43:37.354 INFO [MSC service thread 1–7] [org.jboss.ws.common.management] [] [] JBWS022052: Запуск JBoss Web Services - Stack CXF Server 5.0.0.Final

 

Cause

Это можно увидеть, если службы сервера Appsync запускаются и останавливаются в быстрой последовательности. Существует ряд файлов, например E:\EMC\AppSync\jboss\.\standalone\.. \applications\apollo.ear, которые развертываются сервером Appsync во время запуска. Если служба останавливается до полного развертывания этих файлов, сервер Appsync может начать выдавать эту ошибку.

Проверив расположение C:\EMC\AppSync\jboss\applications, мы должны увидеть следующие 6 файлов в исправной системе: 

  • Аполлон.ухо
  • Аполлоно.EAR.развернуто
  • archway-ear.ear
  • archway-ear.ear.deployed
  • remotex.rar
  • remotex.rar.развернут


Когда мы проверяем систему, показывающую ошибку «Ошибка 404 не найдена», мы должны найти некоторые из этих файлов, помеченных как неразвернутые, например «apollo.ear.undeployed».

Resolution

Временное решение.
Чтобы решить эту проблему, необходимо получить службу сервера Appsync для развертывания . EAR-файлы. Для этого выполните действия, описанные ниже. 
При обнаружении неразвернутых файлов в папке C:\EMC\AppSync\jboss\applications выполните следующие действия для устранения проблемы.

  1. Остановите все службы.
  2. Создайте резервную копию файла C:\EMC\AppSync\jboss\applications.
  3. Переименуйте Apollo.ear.undeployed в Apollo.ear.dodeploy.
  4. Выполните те же шаги, что и в шаге 3, если какие-либо другие файлы EAR также отображаются как неразвернутые.
  5. Запустите службы.
  6. Проверьте состояние . Снова EAR в папке C:\EMC\AppSync\jboss\applications.
i. Аполлон.ухо
II. Apollo.ear.развернутый
III. Арка-ухо.Ухо
iv.archway-ear.ear.deployed
v.remotex.rar
vi.remotex.rar.развернуто
  1. Попробуйте войти в графический интерфейс пользователя appsync через 5 минут, и вы сможете войти в систему.

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000057111
Article Type: Solution
Last Modified: 18 Sep 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.