ViPR SRM: Cannot discover Unity 4.2.x array
Summary: SRM 4.0.2 cannot discover Unity 4.2.x array.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
ViPR SRM version 4.0.2 is unable to discover Unity 4.2.x.
The following error message is received for a test in ViPR SRM:
The following error is received in VNX collector logs:
The following error message is received for a test in ViPR SRM:
Line 327: fail: command returned with a non-zero (status: 1)!
Unsupported API Version: Found API version 6.0
Unsupported API Version: Found API version 6.0
The following error is received in VNX collector logs:
WARNING -- [2017-10-30 04:20:43 PDT] -- HttpRequestGroup::handleResponse(): Unable to connect to host xxx.xxx.xxx.xxx (422) for request https://@{host}/api/types/mgmtInterface/instances?fields=@{mgmtinterface-address-flag}&compact=true&per_page=2000. Server returned the following message: Unprocessable Entity
Cause
ViPR SRM 4.0.2 only supports the API version 5.0. VNX Unity 4.2.x uses API version 6.0.
Resolution
Upgrade ViPR SRM to version 4.1 to discover Unity 4.2.x arrays.
Below is Solution Pack for ViPR SRM 4.1:
Below is Solution Pack for ViPR SRM 4.1:
Affected Products
SRMArticle Properties
Article Number: 000057130
Article Type: Solution
Last Modified: 23 Jul 2021
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.