Сбой ViPR SRM NetApp Collector с ошибкой «Не удалось получить результат подключения»

Summary: ViPR SRM NetApp Collector завершается сбоем через несколько дней с ошибкой «Не удалось получить результат подключения».

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Не удается запустить SRM Collector. 

Эта проблема может возникнуть при обновлении SRM с версии 3.7.x до версии 4.0.3 и продолжиться в версии 4.1.

Сборщик NetApp останавливается каждые несколько дней. В журналах NetApp Collector отображается следующая ошибка:
WARNING -- [2017-05-22 10:06:37 CDT] -- RemoteCLICommandExecutor::getConnectionResults(): Connection result couldn't be retrieved.
java.util.concurrent.ExecutionException: java.io.IOException: com.watch4net.apg.ssh.api.exception.SSHException: com.jcraft.jsch.JSchException: Session.connect: java.io.IOException: java.net.BindException: Address already in use (Bind failed)
Caused by: java.io.IOException: com.watch4net.apg.ssh.api.exception.SSHException: com.jcraft.jsch.JSchException: Session.connect: java.io.IOException: java.net.BindException: Address already in use (Bind failed)
Выполните команду ps  ef | grep 22 на хосте сборщика, на котором возникла проблема. NetApp Collector использует порт 22 для связи с устройствами NetApp. В этом случае в общей сложности 1322 TCP-соединения FIN_WAIT1:
artoxxxxx-col:~ # netstat -ano | grep 22
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      off (0.00/0/0)
tcp        0  61369 xxx.xxx.xxx:50759    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)
tcp        0  61369 xxx.xxx.xxx:58959    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)
tcp        0  61369 xxx.xxx.xxx:56759    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)
tcp        0  61369 xxx.xxx.xxx:49959    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)
tcp        0  61369 xxx.xxx.xxx:59959    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)

Cause

Количество TCP-соединений растет до тех пор, пока не достигнет предельного значения, что не позволит сборщику создавать новые TCP-соединения для связи с другими устройствами.

Resolution

Для решения этой проблемы необходимо сбросить брандмауэр на основном сервере.

  1. Подключитесь по SSH к основному внутреннему серверу, а затем выполните две команды, указанные ниже:
/sbin/SuSEfirewall2 off

/sbin/SuSEfirewall2  on
  1. После завершения подключитесь по SSH к хосту NetApp Collector и выполните следующую команду ( FIN_WAIT1 Подключение больше не должно отображаться):
artxxxxxxx-col:~ # netstat -ano | grep 22
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      off (0.00/0/0)
tcp        0      0 127.0.0.1:40226         0.0.0.0:*               LISTEN      off (0.00/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:60360    xxx.xxx.xxx.xxx:22       ESTABLISHED off (0.00/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:36621    xxx.xxx.xxx.xxx:22       TIME_WAIT   timewait (45.94/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:54396    xxx.xxx.xxx.xxx:22       ESTABLISHED off (0.00/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:49135    xxx.xxx.xxx.xxx:22       TIME_WAIT   timewait (36.91/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:37971    xxx.xxx.xxx.xxx:1521    ESTABLISHED off (0.00/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:54553    xxx.xxx.xxx.xxx:22       TIME_WAIT   timewait (48.97/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:41586    xxx.xxx.xxx.xxx:22       TIME_WAIT   timewait (12.27/0/0)

Affected Products

SRM
Article Properties
Article Number: 000057244
Article Type: Solution
Last Modified: 15 Oct 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.