Échec de ViPR SRM NetApp Collector avec l’erreur « Impossible de récupérer le résultat de la connexion »

Summary: ViPR SRM NetApp Collector échoue au bout de quelques jours avec l’erreur « Le résultat de la connexion n’a pas pu être récupéré ».

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Symptoms

SRM Collector ne parvient pas à démarrer. 

Ce problème peut se produire lors de la mise à niveau vers SRM version 4.0.3 à partir de SRM 3.7.x et se poursuit à la version 4.1.

Le collecteur NetApp s’arrête à quelques jours d’intervalle. Les logs NetApp Collector affichent l’erreur ci-dessous :
WARNING -- [2017-05-22 10:06:37 CDT] -- RemoteCLICommandExecutor::getConnectionResults(): Connection result couldn't be retrieved.
java.util.concurrent.ExecutionException: java.io.IOException: com.watch4net.apg.ssh.api.exception.SSHException: com.jcraft.jsch.JSchException: Session.connect: java.io.IOException: java.net.BindException: Address already in use (Bind failed)
Caused by: java.io.IOException: com.watch4net.apg.ssh.api.exception.SSHException: com.jcraft.jsch.JSchException: Session.connect: java.io.IOException: java.net.BindException: Address already in use (Bind failed)
Exécutez la commande ps  ef | grep 22 Sur l’hôte Collector qui rencontre problème. NetApp Collector utilise le port 22 pour communiquer avec les périphériques NetApp. Dans ce cas, un total de 1 322 connexions TCP a FIN_WAIT1:
artoxxxxx-col:~ # netstat -ano | grep 22
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      off (0.00/0/0)
tcp        0  61369 xxx.xxx.xxx:50759    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)
tcp        0  61369 xxx.xxx.xxx:58959    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)
tcp        0  61369 xxx.xxx.xxx:56759    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)
tcp        0  61369 xxx.xxx.xxx:49959    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)
tcp        0  61369 xxx.xxx.xxx:59959    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)

Cause

Le nombre de connexions TCP augmente jusqu’à ce qu’il atteigne la limite et empêche le Collector d’établir de nouvelles connexions TCP pour communiquer avec d’autres périphériques.

Resolution

Le pare-feu doit être réinitialisé sur le Primary Backend pour résoudre ce problème.

  1. SSH sur votre serveur Primary Backend , puis exécutez les deux commandes ci-dessous :
/sbin/SuSEfirewall2 off

/sbin/SuSEfirewall2  on
  1. Une fois l’opération terminée, connectez-vous en SSH à l’hôte NetApp Collector et exécutez la commande ci-dessous (le FIN_WAIT1 connexion ne devrait plus être vue) :
artxxxxxxx-col:~ # netstat -ano | grep 22
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      off (0.00/0/0)
tcp        0      0 127.0.0.1:40226         0.0.0.0:*               LISTEN      off (0.00/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:60360    xxx.xxx.xxx.xxx:22       ESTABLISHED off (0.00/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:36621    xxx.xxx.xxx.xxx:22       TIME_WAIT   timewait (45.94/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:54396    xxx.xxx.xxx.xxx:22       ESTABLISHED off (0.00/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:49135    xxx.xxx.xxx.xxx:22       TIME_WAIT   timewait (36.91/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:37971    xxx.xxx.xxx.xxx:1521    ESTABLISHED off (0.00/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:54553    xxx.xxx.xxx.xxx:22       TIME_WAIT   timewait (48.97/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:41586    xxx.xxx.xxx.xxx:22       TIME_WAIT   timewait (12.27/0/0)

Affected Products

SRM
Article Properties
Article Number: 000057244
Article Type: Solution
Last Modified: 15 Oct 2025
Version:  3
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