ViPR SRM NetApp Collector зазнає невдачі з помилкою "Не вдалося отримати результат підключення"

Summary: ViPR SRM NetApp Collector виходить з ладу через кілька днів з помилкою "Не вдалося отримати результат підключення".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SRM Collector не може успішно запуститися. 

Ця проблема може з'являтися під час оновлення до версії SRM 4.0.3 з SRM 3.7.x і продовжується в версії 4.1.

Колектор NetApp зупиняється кожні кілька днів. Журнали NetApp Collector показують помилку нижче:
WARNING -- [2017-05-22 10:06:37 CDT] -- RemoteCLICommandExecutor::getConnectionResults(): Connection result couldn't be retrieved.
java.util.concurrent.ExecutionException: java.io.IOException: com.watch4net.apg.ssh.api.exception.SSHException: com.jcraft.jsch.JSchException: Session.connect: java.io.IOException: java.net.BindException: Address already in use (Bind failed)
Caused by: java.io.IOException: com.watch4net.apg.ssh.api.exception.SSHException: com.jcraft.jsch.JSchException: Session.connect: java.io.IOException: java.net.BindException: Address already in use (Bind failed)
Виконайте команду ps  ef | grep 22 на хості-колекторі, який має проблему. NetApp Collector використовує порт 22 для зв'язку з пристроями NetApp. У цьому випадку всього 1322 TCP-з'єднання мають FIN_WAIT1:
artoxxxxx-col:~ # netstat -ano | grep 22
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      off (0.00/0/0)
tcp        0  61369 xxx.xxx.xxx:50759    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)
tcp        0  61369 xxx.xxx.xxx:58959    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)
tcp        0  61369 xxx.xxx.xxx:56759    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)
tcp        0  61369 xxx.xxx.xxx:49959    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)
tcp        0  61369 xxx.xxx.xxx:59959    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)

Cause

Число TCP-з'єднань зростає до тих пір, поки не досягне ліміту, і це не зупинить колектор від виконання нових TCP-з'єднань для зв'язку з іншими пристроями.

Resolution

Щоб вирішити цю проблему, потрібно скинути налаштування брандмауера на основному сервері.

  1. SSH у ваш основний сервер , а потім запустіть дві наведені нижче команди:
/sbin/SuSEfirewall2 off

/sbin/SuSEfirewall2  on
  1. Після завершення встановіть SSH на хост NetApp Collector і виконайте команду нижче (кнопка FIN_WAIT1 з'єднання більше не повинно бути видно):
artxxxxxxx-col:~ # netstat -ano | grep 22
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      off (0.00/0/0)
tcp        0      0 127.0.0.1:40226         0.0.0.0:*               LISTEN      off (0.00/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:60360    xxx.xxx.xxx.xxx:22       ESTABLISHED off (0.00/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:36621    xxx.xxx.xxx.xxx:22       TIME_WAIT   timewait (45.94/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:54396    xxx.xxx.xxx.xxx:22       ESTABLISHED off (0.00/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:49135    xxx.xxx.xxx.xxx:22       TIME_WAIT   timewait (36.91/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:37971    xxx.xxx.xxx.xxx:1521    ESTABLISHED off (0.00/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:54553    xxx.xxx.xxx.xxx:22       TIME_WAIT   timewait (48.97/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:41586    xxx.xxx.xxx.xxx:22       TIME_WAIT   timewait (12.27/0/0)

Affected Products

SRM
Article Properties
Article Number: 000057244
Article Type: Solution
Last Modified: 15 Oct 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.