Avamar: Zálohování virtuálního počítače na úrovni bitové kopie selhává s chybou nečinnosti snímku
Summary: Tento článek obsahuje informace o selhávání zálohování na úrovni bitové kopie virtuálního počítače s chybou uvedení snímku do nečinnosti.
Symptoms
Zálohování bitové kopie virtuálního počítače selhává s chybou nečinnosti snímku, jak je znázorněno níže.
avvcbimage Warning <16277>: vSphere Task failed (application quiesce): 'An error occurred while quiescing the virtual machine. See the virtual machine's event log for details.
avvcbimage Warning <43652>: Snapshot 'Avamar-1577539864a83b60c2d81fb0e6234f5e956e1bedb51d697138' creation for VM '[XXYY-XXYY01] testxyz2473_1/testxyz2473_1.vmx' task creation encountered a quiesce problem
avvcbimage Error <43650>: File level consistent snapshot quiesce failure.
Při ručním pořizování snímku to funguje dobře.
Cause
V prostředí virtuálního počítače došlo k problému s prostředky při vstupně-výstupních operacích disku a využití paměti. Systém VMware vCenter verze 6.5 a novější představil novou funkci služby Stínová kopie svazku (VSS), která se nazývá rozšířené snímky (CreateSnapshotEx_Task) Nahrazení staré funkce "CreateSnapshot_Task."
Níže naleznete informace v informacích o vydání VMware.
Verze 6.5 obsahuje podporu dalších konfigurací zálohování služby Stínová kopie svazku (VSS).
- Skript
vssBackupType VSS_BT_COPYse dříve používal jako výchozí proCreateSnapshot_Taskale teďVSS_BT_FULL, VSS_BT_INCREMENTAL, VSS_BT_DIFFERENTIAL,aVSS_BT_LOGjsou také k dispozici. - Skript
vssBackupContextje zaveden pro vynucení nečinnosti aplikace nebo souborového systému. - Časový limit (výchozí = 15 minut) pro uvedení virtuálních počítačů do nečinnosti je možné nakonfigurovat kdekoli od 5 minut do 4 hodin.
Aby bylo možné tyto nové funkce a konfigurace podporovat, funkce CreateSnapshotEx_Task byl přidán do rozhraní vSphere API, nahrazující CreateSnapshot_Task.
Resolution
Když se tým virtuálního počítače pokusil o rozšířený snímek ručně pomocí prohlížeče vCenter Managed Object Browser (MOB), došlo k selhání kvůli problémům souvisejícím se systémem VMware. Problém se zálohováním byl vyřešen poté, co tým VMware opravil všechny problémy související se systémem VMware, včetně problému se vstupně-výstupními operacemi disku na daném virtuálním počítači, a bylo možné pořídit snapshot ze zálohy MOB i Avamar.