로그 격차 및 sqlmeta.xml 파일로 인해 Avamar SQL 클러스터 백업이 실패했습니다.
Summary: 로그 격차 및 sqlmeta.xml 파일로 인해 Avamar SQL 클러스터 백업이 실패했습니다.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
SQL 클러스터 또는 SQL AG에 대한 SQL 증분 백업이 실패하고 다음 오류가 발생합니다.
542 행 : 2019/12/05-16:49:56.85100 [avsql_assist] avspawn::run_and_wait 대기 error_num:536870919 wait_error:0에서 돌아옴 547 행 : 2019-12-05 17:49:56 avsql 경고 <7427>: SQL 메타데이터를 로드하는 중 오류 발생 555 행 : avtar 오류 <5195> : 백업에 ".system_info\sqlmeta" 경로가 없습니다. (검색 경로 '.system_info\sqlmeta'의 위치 1에 있는 'sqlmeta' 요소를 찾을 수 없음) 634 행 : 2019-12-05 17:49:57 avsql 오류 <40418> : 다음 이유로 인해 'sql-listener\VIEWSQL/viewupdmgr' 데이터베이스를 건너뜁니다. 로그 간격이 확인되었거나 전체 백업을 찾을 수 없습니다. 755 행 : 2019/12/05-16:50:04.42799 [avsql_assist] avspawn::run_and_wait 대기 error_num:536870919 wait_error:0에서 돌아옴 755 행 : 2019/12/05-16:50:04.42799 [avsql_assist] avspawn::run_and_wait 대기 error_num:536870919 wait_error:0에서 돌아옴 762 행 : 2019-12-05 17:50:04 avsql 경고 <7427> : SQL 메타데이터를 로드하는 중 오류 발생 770 행 : avtar 오류 <5195> : 백업에 ".system_info\sqlmeta" 경로가 없습니다. (검색 경로 '.system_info\sqlmeta'의 위치 1에 있는 'sqlmeta' 요소를 찾을 수 없음) 849 행 : 2019-12-05 17:50:05 avsql 오류 <40418> : 다음과 같은 이유로 인해 'sql-listener\VIEWSQL/viewevent' 데이터베이스를 건너뜁니다. 로그 간격이 확인되었거나 전체 백업을 찾을 수 없습니다.
Cause
로그 갭 문제는 이전 SQL 백업에서 sqlmeta.xml 파일을 읽지 못해 발생하며 백업이 sqlmeta.xml not found로 실패합니다.
Resolution
아래 단계를 확인하십시오.
1) c:\temp가 없는 경우 만들고 기본 SQL 노드의 Avamar BIN 폴더에서 cd하는 동안 관리자 권한으로 실행합니다.
avtar --list --debug --server=<Avamar_server> --id=MCUser --ap=MCUser_password --path=<path_to_client> --labelnum="91631" --noinfo --noconfig --logfile=c:\temp\backup_list.log
여기서 --labelnum="91631"은 백업 레이블 번호입니다.
2) 위 명령의 출력에 sqlmeta.xml 파일이 있는지 확인합니다.
파일이 있는 경우 아래 명령을 사용하여 백업에서 '.system_info'의 복원을 시도합니다.
avtar -x --debug --server=<Avamar_server> --id=MCUser --ap=MCUser_password --path=<path_to_client> --labelnum="91631" --noinfo --noconfig ".system_info" --target=c:\temp\ --logfile=c:\temp\system_info.log --internal
3) sqlmeta.xml 파일이 백업 레이블(위)에 없으면 다음을
시도하십시오.--클러스터/공유 var 디렉토리에 sqlmeta.xml 파일이 있는지 확인합니다. 파일이 있는 경우 파일을 삭제하거나 다른 위치로 이동합니다.
--파일을 삭제/이동한 후 전체 백업을 수행한 다음 증분 백업을 수행합니다.
--전체 백업을 실행한 후 증분 백업을 실행하면 새 sqlmeta.xml 파일이 생성됩니다.
1) c:\temp가 없는 경우 만들고 기본 SQL 노드의 Avamar BIN 폴더에서 cd하는 동안 관리자 권한으로 실행합니다.
avtar --list --debug --server=<Avamar_server> --id=MCUser --ap=MCUser_password --path=<path_to_client> --labelnum="91631" --noinfo --noconfig --logfile=c:\temp\backup_list.log
여기서 --labelnum="91631"은 백업 레이블 번호입니다.
2) 위 명령의 출력에 sqlmeta.xml 파일이 있는지 확인합니다.
파일이 있는 경우 아래 명령을 사용하여 백업에서 '.system_info'의 복원을 시도합니다.
avtar -x --debug --server=<Avamar_server> --id=MCUser --ap=MCUser_password --path=<path_to_client> --labelnum="91631" --noinfo --noconfig ".system_info" --target=c:\temp\ --logfile=c:\temp\system_info.log --internal
3) sqlmeta.xml 파일이 백업 레이블(위)에 없으면 다음을
시도하십시오.--클러스터/공유 var 디렉토리에 sqlmeta.xml 파일이 있는지 확인합니다. 파일이 있는 경우 파일을 삭제하거나 다른 위치로 이동합니다.
--파일을 삭제/이동한 후 전체 백업을 수행한 다음 증분 백업을 수행합니다.
--전체 백업을 실행한 후 증분 백업을 실행하면 새 sqlmeta.xml 파일이 생성됩니다.
Additional Information
이 콘텐츠는 다음과 같은 여러 언어로 번역되어 있습니다.
| https://downloads.dell.com/TranslatedPDF/AR-SA_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/DE_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/ES_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/ES-XL_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/FR_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/IT_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/JA_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/KO_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/NL_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/PT_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/PT-BR_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/RU_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/SV_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-CN_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-TW_539981.pdf |
Affected Products
AvamarProducts
AvamarArticle Properties
Article Number: 000057398
Article Type: Solution
Last Modified: 05 Sep 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.