Back-ups van Avamar SQL cluster zijn mislukt met logboekkloof en sqlmeta.xml-bestand

Summary: Back-ups van Avamar SQL cluster zijn mislukt met logboekkloof en sqlmeta.xml-bestand

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Incrementele SQL-back-ups voor een SQL-cluster of SQL AG mislukken met de volgende fouten:
 
Lijn 542: 2019/12/05-16:49:56.85100 [avsql_assist] avspawn::run_and_wait terug van wachten error_num:536870919 wait_error:0
	Lijn 547: 2019-12-05 17:49:56 avsql Warning <7427>: Fout bij laden van SQL-metadata
	Regel 555: avtar Fout <5195>: Pad ".system_info\sqlmeta" niet gevonden in back-up. (Element 'sqlmeta' op positie 1 in zoekpad '.system_info\sqlmeta' niet gevonden)
	Lijn 634: 2019-12-05 17:49:57 avsql Error <40418>: Overslaan van database 'sql-listener\VIEWSQL/viewupdmgr' om de volgende reden: Er is een logfout geïdentificeerd of er is geen volledige back-up gevonden.
	Lijn 755: 2019/12/05-16:50:04.42799 [avsql_assist] avspawn::run_and_wait terug van wachten error_num:536870919 wait_error:0
	Lijn 755: 2019/12/05-16:50:04.42799 [avsql_assist] avspawn::run_and_wait terug van wachten error_num:536870919 wait_error:0
	Lijn 762: 2019-12-05 17:50:04 avsql Warning <7427>: Fout bij laden van SQL-metadata
	Regel 770: avtar Fout <5195>: Pad ".system_info\sqlmeta" niet gevonden in back-up. (Element 'sqlmeta' op positie 1 in zoekpad '.system_info\sqlmeta' niet gevonden)
	Lijn 849: 2019-12-05 17:50:05 avsql Error <40418>: Overslaan van database 'sql-listener\VIEWSQL/viewevent' om de volgende reden: Er is een logfout geïdentificeerd of er is geen volledige back-up gevonden.

Cause

Het probleem met de logboekkloof wordt veroorzaakt doordat het sqlmeta.xml-bestand van de vorige SQL-back-ups niet kan worden gelezen en de back-ups mislukken waarbij sqlmeta.xml niet gevonden.

Resolution

Controleer de onderstaande stappen:
1) Maak c:\temp als deze niet bestaat, voer deze uit als admin terwijl cd in de Avamar BIN-map op het primaire SQL-knooppunt staat: 

 avtar --list --debug --server=<Avamar_server> --id=MCUser --ap=MCUser_password --path=<path_to_client> --labelnum="91631" --noinfo --noconfig --logfile=c:\temp\backup_list.log
 
waarbij --labelnum="91631" het back-up labelnummer is.
 
 2) Controleer of het sqlmeta.xml bestand aanwezig is in de opdracht Uitvoer van hierboven.
 
 Als het bestand aanwezig is, probeer dan '.system_info' vanuit de back-up te herstellen met de onderstaande opdracht:
     avtar -x --debug --server=<Avamar_server> --id=MCUser --ap=MCUser_password --path=<path_to_client> --labelnum="91631" --noinfo --noconfig ".system_info" --target=c:\temp\ --logfile=c:\temp\system_info.log --internal

3) Als sqlmeta.xml bestand niet bestaat in het back-uplabel (hierboven), probeer dan dit--Controleer of
er een sqlmeta.xml bestand in de cluster/gedeelde var-directory staat, Als het bestand bestaat, verwijdert u het bestand of verplaatst u het naar een andere locatie. 
--Na het verwijderen/verplaatsen van het bestand voert u volledige back-ups en vervolgens incrementele back-ups uit.
--Het uitvoeren van een volledige back-up gevolgd door een incrementele back-up zorgt ervoor dat een nieuw sqlmeta.xml bestand wordt gemaakt.

Additional Information

Deze inhoud is vertaald in verschillende talen: 
https://downloads.dell.com/TranslatedPDF/AR-SA_539981.pdf
https://downloads.dell.com/TranslatedPDF/DE_539981.pdf
https://downloads.dell.com/TranslatedPDF/ES_539981.pdf
https://downloads.dell.com/TranslatedPDF/ES-XL_539981.pdf
https://downloads.dell.com/TranslatedPDF/FR_539981.pdf
https://downloads.dell.com/TranslatedPDF/IT_539981.pdf
https://downloads.dell.com/TranslatedPDF/JA_539981.pdf
https://downloads.dell.com/TranslatedPDF/KO_539981.pdf
https://downloads.dell.com/TranslatedPDF/NL_539981.pdf
https://downloads.dell.com/TranslatedPDF/PT_539981.pdf
https://downloads.dell.com/TranslatedPDF/PT-BR_539981.pdf
https://downloads.dell.com/TranslatedPDF/RU_539981.pdf
https://downloads.dell.com/TranslatedPDF/SV_539981.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_539981.pdf
https://downloads.dell.com/TranslatedPDF/ZH-TW_539981.pdf

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000057398
Article Type: Solution
Last Modified: 05 Sep 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.