Symptoms
Podczas korzystania z interfejsu użytkownika ECS do śledzenia operacji (operacji zasobnika, tak dalej) ścieżka inspekcji (monitor > zdarzenia > audyt) nie wypełnia się odpowiednimi informacjami. Zamiast tego wygeneruj poniższe dane wyjściowe błędu:
Błąd 7000 (http: 500): Wystąpił błąd w usłudze API. Wystąpił błąd w usłudze API. Przyczyna: zdarzenia inspekcji listy błędów.
Dzienniki inspekcji operacji nie powinny być wypełniane w tym scenariuszu.
Uwaga: Wystąpienia tego problemu mogą mieć charakter przejściowy (czyli: Baner błędu może zostać wygenerowany jeden raz i nie pojawiać się przy ponownej próbie, ale problem może nadal być prawidłowy).
Cause
Jest to znany problem z kodem, który może wystąpić przed kodem ECS w wersji 3.4.0.1 GP 1.
Resolution
Rozwiązanie tego problemu znajduje się w kodzie ECS 3.4.0.1 GP 1.
Obejście problemu przy użyciu interfejsu wiersza poleceń jest dostępne poprzez wygenerowanie danych wyjściowych raw.xml w następujący sposób (
Uwaga: Usunięcie potoku w poleceniu poniżej przed
head-12 powoduje wygenerowanie dalszych informacji dziennika inspekcji):
admin@ecs1:~> svc_rest_cmd /vdc/events | head -12 svc_rest_cmd 1.0.10 User emcservice logged in successfully Update urn:storageos:Zdarzenie:xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx emcservice Login2020-01-23T12:45:27 emcservice
Jeśli wymagana jest dalsza pomoc, otwórz zgłoszenie serwisowe w pomocy technicznej ECS i zapoznaj się z tym artykułem bazy wiedzy w uwagach żądania serwisowego.
Additional Information
Podręcznik referencyjny interfejsu REST API jest dostępny na stronie pobierania ECS. Znajduje się w witrynie pomocy technicznej firmy Dell.