VxRail: Node health-check fails for test 'mem_c'

Summary: Correctable memory issues reporting during upgrade pre-check

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

VxVerify runs several tests on each node by uploading a "minion" heath-check program, which detects issues that may cause upgrades to fail. Once the minion finishes, it saves a JSON file, which is then automatically retrieved with VxVerify. The JSON from each node is the merged with the VxRM based healthcheck results to produce a report for the whole cluster.

In this case, the test is 'mem_c', which uses ipmitool for health-checks.

If the test passes, it returns the following event:
0 (green)

If the test cannot access the necessary information or finds a warning level event, it returns the following code:
1 (yellow)

A failure, which must be addressed prior to any upgrade, returns the following code:
2 (red)

 

Cause

Pre-existing memory issues may cause issues with the upgrade which may cause the node to stay down in need of user intervention. These should be resolved prior to upgrade, if possible.

If it is not possible to resolve the pre-upgrade, be aware that the node on reboot may stay down, Check the iDRAC console and remedy.

 

Resolution

VxVerify Error:

| ESXi-01   | 2 Fail | 537534 | mem_c: IPMI error logging disabled

In vCenter UI:

  1. Select the ESXi Node > Monitor > Hardware Health > Select SYSTEM EVENT LOG
  2. Export the log to save it.
  3. Once saved, click "Reset Event Log."
    Note: In some cases, you may also require reset iDRAC.
  4. Rerun the VxVerify script to determine if the error is now gone.

 

Affected Products

VxRail
Article Properties
Article Number: 000058593
Article Type: Solution
Last Modified: 11 Dec 2024
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.