Dell Unity. Сбой обновления ПО с ошибкой диагностики системы:check_replication
Summary: Происходит сбой обновления ПО Dell Unity с ошибкой «Health Check Error:check_replication_health_2, check_replication_health_5». Также может произойти сбой обновления ПО с сообщением «Warning: check_replication_health_4». ...
Symptoms
Сообщения диагностики системы модернизации и события: оповещения:
ошибкиThe health check has failed. One or more remote system problems were detected on the system and causes the upgrade to fail. Record the error code and search the Dell Online Support website for available support options.[Error Code: platform::check_replication_health_2]-------------------------------------Errors-------------------------------------Platform: Check replication healthSync is in progress for the following replication sessions: * VRT_xxxx_xxAction : Cannot perform upgrade while a sync is in progress for a replication session. Please wait until the sync completes or pause the sessions and retry the upgrade.ERROR_CODE=platform::check_replication_health_5|Error|VRT_xxxx_xxEvents > Alerts > Information: The remote system connection is out of date. Update the connection with the latest interface changes.WarningsOne or more replication sessions are configured to be auto-synchronized. This could cause a problem during an upgrade. Pause the replication sessions prior to starting the upgrade and resume them after completing the upgrade. [Warning Code=platform::check_replication_health_4]/nas/log/check_health.161031-152020.log------------------------------------Warnings------------------------------------Platform: Check replication healthThe following replication sessions should be paused prior to starting the upgrade: * rep_sess_res_84_res_1_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx * rep_sess_res_85_res_2_FNMxxxxxxxxxxx_FNMxxxxxxxxxxxAction : Since these are auto-synchronized sessions, they could get into critical state if replication attempts a sync during the upgrade. To avoid this issue, please pause these sessions before starting the upgrade and resume them after the upgrade.ERROR_CODE=platform::check_replication_health_4|Warning|rep_sess_nas_44_nas_1_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx* rep_sess_res_84_res_1_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx* rep_sess_res_85_res_2_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx-------------------------------------Errors-------------------------------------Platform: Check replication healthThe following remote systems have health problems: * FNMxxxxxxxxxxxAction : Escalate this issue through your support organization and provide this output in your escalation.ERROR_CODE=platform::check_replication_health_2|Error|FNMxxxxxxxxxxx--------------------------------------------------------------------------------UPGRADE CANNOT PROCEED.Check Result: Errorspb:~$ uemcli /remote/sys -id RS_1 show -detail |grep Health Health state = Minor failure (15) Health details = "Update the remote system connection to pick up the latest interface changes on the local and remote systems."
ЮНИСФЕРА > Соединения репликации >При наведении курсора на треугольник с предупреждением отображается следующее:"Update the remote system connection to pick up the latest interface changes on the local and remote systems."
Cause
- Основной причиной ошибки диагностики системы является необходимость обновления соединения между двумя (2) системами репликации. Подключения репликации требуют ручного обновления при каждой перезагрузке процессоров СХД или перезапуске службы управления системой.
- Чтобы получить предупреждение диагностики системы, необходимо приостановить сессии репликации на сервере сетевой системы хранения данных исходной системы и в каждой отдельной файловой системе.
ПРИМЕЧАНИЕ. При приостановке репликации на исходной стороне состояние репликации на целевой стороне изменяется на «приостановлено».
Resolution
Для сообщения «Warning» приостановите все сессии репликации из исходной системы, что приведет к приостановке всех соответствующих сессий назначения:
Решение: Приостановите все сессии
репликации исходной системыСессии > репликации > Unisphere > Другие действия > Приостановить
В случае сбоя сообщения об ошибке обновите свои подключения репликации>:
Решение: Обновление удаленного подключения из исходной системы
Проверка и обновление соединений > для репликации > Unisphere >
ПРИМЕЧАНИЕ. Подключение должно обновиться и отобразить состояние зеленой проверки.