Dell Unity:ソフトウェア アップグレードがヘルス チェック エラーで失敗する:check_replication
Summary: Dell Unityソフトウェアのアップグレードが「ヘルス チェック エラー:check_replication_health_2、check_replication_health_5」で失敗します。ソフトウェア アップデートが「Warning: check_replication_health_4」で失敗する可能性もあります。
Symptoms
アップグレード ヘルス チェックのメッセージとイベント アラート:
ErrorsThe health check has failed. One or more remote system problems were detected on the system and causes the upgrade to fail. Record the error code and search the Dell Online Support website for available support options.[Error Code: platform::check_replication_health_2]-------------------------------------Errors-------------------------------------Platform: Check replication healthSync is in progress for the following replication sessions: * VRT_xxxx_xxAction : Cannot perform upgrade while a sync is in progress for a replication session. Please wait until the sync completes or pause the sessions and retry the upgrade.ERROR_CODE=platform::check_replication_health_5|Error|VRT_xxxx_xxEvents > Alerts > Information: The remote system connection is out of date. Update the connection with the latest interface changes.WarningsOne or more replication sessions are configured to be auto-synchronized. This could cause a problem during an upgrade. Pause the replication sessions prior to starting the upgrade and resume them after completing the upgrade. [Warning Code=platform::check_replication_health_4]/nas/log/check_health.161031-152020.log------------------------------------Warnings------------------------------------Platform: Check replication healthThe following replication sessions should be paused prior to starting the upgrade: * rep_sess_res_84_res_1_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx * rep_sess_res_85_res_2_FNMxxxxxxxxxxx_FNMxxxxxxxxxxxAction : Since these are auto-synchronized sessions, they could get into critical state if replication attempts a sync during the upgrade. To avoid this issue, please pause these sessions before starting the upgrade and resume them after the upgrade.ERROR_CODE=platform::check_replication_health_4|Warning|rep_sess_nas_44_nas_1_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx* rep_sess_res_84_res_1_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx* rep_sess_res_85_res_2_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx-------------------------------------Errors-------------------------------------Platform: Check replication healthThe following remote systems have health problems: * FNMxxxxxxxxxxxAction : Escalate this issue through your support organization and provide this output in your escalation.ERROR_CODE=platform::check_replication_health_2|Error|FNMxxxxxxxxxxx--------------------------------------------------------------------------------UPGRADE CANNOT PROCEED.Check Result: Errorspb:~$ uemcli /remote/sys -id RS_1 show -detail |grep Health Health state = Minor failure (15) Health details = "Update the remote system connection to pick up the latest interface changes on the local and remote systems."
Unisphere > レプリケーション > 接続
警告の三角形にカーソルを合わせると、次のように表示されます。"Update the remote system connection to pick up the latest interface changes on the local and remote systems."
Cause
- ヘルス チェック エラーの失敗の根本的な原因は、2つのレプリケーション システム間の接続を更新する必要があることです。SP(ストレージ プロセッサ)が再起動された場合、またはシステム管理サービスが再起動された場合は、レプリケーション接続を手動で更新する必要があります。
- ヘルス チェックの警告については、ソース システムNASサーバーと個々のファイル システムでレプリケーション セッションを 一時停止 する必要があります。
メモ: ソース側を一時停止すると、デスティネーション側のレプリケーションの状態が一時停止に変わります。
Resolution
警告メッセージの場合は、ソース システムからのすべてのレプリケーション セッションを一時停止します。これにより、それぞれのデスティネーション セッションも一時停止します。
解決策: すべてのソース レプリケーション セッションを一時停止
Unisphere > Replication > Sessions> More Actions > Pause]
エラー メッセージが失敗した場合は、レプリケーション >接続をアップデートします。
解決方法: ソース システムからのリモート接続の更新
Unisphere > レプリケーション > 接続 > 検証および更新
メモ: 接続がアップデートされ、緑色のチェック ステータスが表示されます。