PowerScale: Isilon: Using sudo account after upgrade fails with "USER is not in the sudoers file. This incident is reported." (User Correctable)

Summary: Sudo accounts in a limited number of OneFS versions were created using a workaround. When the cluster is upgraded to a OneFS code version where the issue was fixed, those sudo accounts do not work correctly. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Code was upgraded from a version of OneFS where isi_visudo was not working to a newer version of OneFS where isi_visudo was fixed.

sudo accounts established on a OneFS version with a defective isi_visudo experienced errors with sudo after upgrading to a rectified code version (such as, v8.1.0.4). Despite sudo account entries being confirmed in /etc/mcp/override/sudoers and /usr/local/etc/sudoers—which require root access—sudo did not function properly.

More output from the non-working sudo account can look like the following output, in addition to the USERNAME is not in the sudoers file error:

MYCLUSTER-13% sudo isi status
We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:
    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.
Password:
Sorry, user USERNAME is not allowed to execute '/usr/bin/isi status' as root on mycluster-13.

Cause

The issue is related to the OneFS code.

Resolution

Log in as the root user, and:

  1. Use
    isi_visudo
    and delete the USER account that was set up for sudo. Be careful only to delete the sudo account which is not working. Save the File. 
    :wq!
  2. Use
    isi_visudo
    and re-create the USER account with the correct settings. Save the File.

The code upgrade should not affect the roles and other authorizations. The user account and password remain unchanged. After performing the above steps, the account will function again.

Affected Products

Isilon

Products

Isilon, PowerScale OneFS
Article Properties
Article Number: 000059475
Article Type: Solution
Last Modified: 01 Apr 2025
Version:  4
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