DPA: El agente no se puede conectar a Avamar Server, error "No se pudo determinar la versión de la base de datos"
Summary: El agente de Data Protection Advisor (DPA) no puede conectarse a Avamar Server. Error de registro del agente "No se pudo determinar la versión de la base de datos: Falló la conexión a la base de datos mcdb: no se pudo conectar al servidor: Se agotó el tiempo de espera de la conexión" ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
La recolección de datos falla para un servidor Avamar.
Al examinar el registro del agente de DPA o la pantalla del historial de solicitudes, se observa el siguiente error:
DBG1 9695.8 20170403:115705 sodbc.pgsql.connect - cpgsqlConnect(): Failed to determine database version: Connection to database mcdb failed: could not connect to server: Connection timed out Is the server running on host "test.avamar" (192.xxx.x.xx) and accepting TCP/IP connections on port 5555?
Cause
Este error indica que el agente de DPA no puede establecer una conexión con el servidor Avamar.
Algunos factores ambientales no relacionados con DPA pueden causar este problema:
- Problemas de conectividad de red
- Problemas de resolución de nombres
- Problemas de configuración de conexión de Avamar
Resolution
Los siguientes pasos se pueden utilizar para probar la conectividad de red:
- Haga ping a Avamar desde el servidor del agente DPA. Si no hay respuesta, se trata de un problema de red.
- Si se recibe una respuesta al ping, desde un sistema Linux o Windows PowerShell, puede ejecutar lo siguiente para probar la conexión del puerto:
curl -kv <avamar FQDN or IP>:5555
- En una buena respuesta cuando se puede acceder al puerto, la línea "Conectado a" está ahí, lo que indica que se realizó una conexión. Consulte el ejemplo a continuación:
curl -kv 10.x.x.x:5555 * Trying 10.x.x.x:5555... * Connected to 10.x.x.x (10.x.x.x) port 5555 (#0) > GET / HTTP/1.1 > Host: 10.x.x.x:5555 > User-Agent: curl/8.0.1 > Accept: */* > * Empty reply from server * Closing connection 0 curl: (52) Empty reply from server
- Si la línea "Conectado a" no está ahí, o aparece "No se pudo conectar", "No conectado" o deja de responder y no da respuesta, esto indica un problema de conexión de red.
- Esto requiere que el administrador de red investigue el entorno para resolver el problema de conexión de red.
- Si el comando CURL se conecta, abra una solicitud de servicio (SR) con el soporte de Dell.
Comuníquese con el soporte de Dell para obtener más detalles o información.
Affected Products
Data Protection AdvisorProducts
AvamarArticle Properties
Article Number: 000059572
Article Type: Solution
Last Modified: 23 Jul 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.