VxRail: iSCSI datastore causing host not responding and all VMs on it disconnected

Summary: iSCSI datastore causing host not responding and all VMs on it disconnected because of some of the hosts have SW iSCSI with port binding and vmk's in different subnets. and when using different subnets , The port binding should be removed ...

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Symptoms



- Host connection and power state Dial home or customer reporting host not responding from the vCenter view and all the VMs in that host not responding, yet the host itself is reachable on the network and all the VMs on it are accessible.
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The host itself and the VMs are reachable on the network.
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Cause

-One or more VMs are connected to iSCSI datastore, While some of the hosts have SW iSCSI with port binding and vmk's in different subnets.
 
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For Example :
Adapter  Vmknic  IPv4            IPv4 Subnet Mask
-------  ------  ----            ----------------
vmhba40  vmk4    XXX.XXX.241.XX  255.255.255.0
vmhba40  vmk5    XXX.XXX.244.XX   255.255.255.0

==This deployment usually required by RecoverPoint

Resolution

Remove the port binding as we don't need a port binding if the iSCSI and vmk ports are on different subnet.

Action Plan :
To remove the vmk's from port binding, Please follow procedure below:
1) Migrate all VMs to other servers
2) Get the host into Maintenance mode
3) Unmount all iSCSI datastores (unmount, DO NOT delete them)
4) Remove the vmkernel ports from port binding   if you get prompted that you are about to remove the last vmkernel port from the setup, click YES
The steps to Remove the vmkernel ports from port binding:

https://pubs.vmware.com/vsphere-60/index.jsp?topic=%2Fcom.vmware.vsphere.html.hostclient.doc%2FGUID-94CBA46B-B8B8-4377-B936-CC71C1880E02.html

5) Perform a storage rescan
6) Reboot the server
7) Exit maintenance mode
8) Migrate VMs from another host to the updated host, and repeat the process


Affected Products

VxRail Appliance Family

Products

RecoverPoint, VxRail Appliance Family
Article Properties
Article Number: 000059616
Article Type: Solution
Last Modified: 10 May 2023
Version:  3
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