Data Domain: DDMC or DDMS cannot add DDR hosts due to duplicate UUID

Summary: If a Data Domain system’s hostname is used by another Data Domain, the hostname to UUID mapping remains in the registry. This causes a duplicate UUID event.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

DDMC or DDMS cannot add DDR hosts because of duplicate UUID.
DDMC reports an error such as:  Host dd11.emc.com is already being managed as dd22.emc.com.
DDMS (System Manager) reports an error such as: "cannot add DD_managed-host, host exists already".

Cause

This issue is triggered by hostname re-use on a Data Domain that is a part of a DDMC or DDEM inventory.  DDMC and DDMS use the UUID of a DDR for identification.  We have discovered that if a Data Domain system s hostname gets inherited by another Data Domain, the local UUID remains in the registry.  We have identified this behavior in a few scenarios:
 
When a Data Domain is added to a DDMC and DDMS inventory, we use the UUID to check if the system is in the list.  A hostname is retired off of one Data Domain but then later added to another Data Domain/DDMC controller.  The UUID is still mapped to the hostname causing an error message that this DDR is already managed/ already exists.

Resolution

There is only a workaround for this issue which is resetting the UUID. 
 
First, identify there is a duplicate UUID instance:

Autosupport: In the DDMC or DDMS controller's autosupport, grab a list of the UI inventory under protocol.gui.ddem.inventory. Identify a duplicate UUID in the inventory list. You can also search by config.local.node_uuid.

Once the Data Domain duplicate UUID is discovered, remove the UUID registry from the Data Domain that you are not able to register.  This action can only be done with the command-line interface and requires SE privilege.

NOTE: SE commands have been deprecated in DDOS versions 7.7.5.25, 7.10.1.15, 7.13.0.15, 6.2.1.110 and above and are accessible only by Dell employees.
SE## reg show config.local.node_uuid
Identify this is the duplicate UUID that you've found in the inventory list
SE## reg remove config.local.node_uuid
NO OTHER ACTION IS REQUIRED. The system identifies no UUID is set and assign a new one.
Now go to your DDMC/ DDMS controller and try adding the Data Domain to its inventory.

Additional Information

If the issue still persists, collect a support bundle and contact Dell Support for further assistance.

Affected Products

PowerProtect Data Domain Management Center

Products

Data Domain, PowerProtect Data Domain Management Center
Article Properties
Article Number: 000059684
Article Type: Solution
Last Modified: 11 Dec 2023
Version:  3
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