Data Protection Advisor (DPA): Receive errors in server logs after upgrade.

Summary: This article explains the resolution when there are errors in server logs after upgrade. These errors were displayed: ‘Unable to get managed connection for java:jboss/datasources/ApolloDS’ and ‘password authentication failed for user "apollouser"' ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The Application services fail to start after applying upgrade. 

The Application server for the services showed as  Starting    while the Datastore services are in a Running state.

The following errors are seen in the server.logs on the Application server:     
 
2019-11-25 12:02:06,487 WARN  [org.hibernate.engine.jdbc.internal.JdbcServicesImpl] (ServerService Thread Pool -- 75) HHH000342: Could not obtain connection to query metadata : javax.resource.ResourceException: IJ000453: Unable to get managed connection for java:jboss/datasources/ApolloDS
 >>


Caused by: org.postgresql.util.PSQLException: FATAL: password authentication failed for user "apollouser"

Cause

An incorrect Datastore password was entered in the upgrade wizard during the upgrade of the Application server, thus the Application server was unable able to connect to the Datastore server. This prevented the Application services from starting. 

Resolution

Reset the Datastore password and restart services on the Datastore and Application servers with the following steps:    
  1. Stop the Application services
  2. On the Datastore server, reset the Datastore password via the command:   
dpa ds dspassword
  1. Restart DS services
  2. Start the Application services
  3. From on the Application server, reset the Datastore password via the command:   
dpa app dspassword
  1. Restart Application services

After completing the above steps, the Application services will move to a  deployed  state and the DPA GUI will launch successfully.

For further information, refer to the  DPA command line operations  section in the technical documentation:    
https://support.emc.com/docu93953_Data_Protection_Advisor_19.1_Installation_and_Administration_Guide.pdf?language=en_US&source=Coveo

Contact Dell EMC Technical Support for further details or information.

Affected Products

Data Protection Advisor
Article Properties
Article Number: 000060319
Article Type: Solution
Last Modified: 29 Aug 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.