Dell Unity: Unable to detect an Ethernet port or link aggregation on which the NAS server network interface was configured

Summary: Async replication remote physical must match the source side, otherwise an override is required.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A Unity user is receiving the following error message in Unisphere on the DR site:

The system is unable to detect an Ethernet port or link aggregation on which the NAS server network interface was configured. Switch the interface to use another Ethernet port or link aggregation. If this does not help, restart the management software. If the problem persists, contact your service provider.

 

Cause

There is no matching physical interface on the source for the specified NAS server. As a result, it cannot properly failover.
Edit NAS Server Network Interface

Note the IPs are removed intentionally, however the key take is the Ethernet Port missing (dash)

 

Resolution

  1. On the Destination Array for the affected NAS Server, open the NAS Server Properties.
  2. Choose the Network Tab and select the IP address assigned and choose Edit.
  3. In the Edit NAS Server Interface window that appears, select the Override IP checkbox, configure the same IP as the production NAS server on Different physical network or interface or specify a different IP with a different physical interface. Select the appropriate physical network interface of your choice.
    Edit NAS Server Network Interface

Screenshot of Override Address Checkbox activated. Note all IP addresses removed from the screenshot.

 

Additional Information

Pre Upgrade Health Check Errors:

ERROR_CODE=dm::check_nas_servers_health_2|Error|nasservervdm4 - The system is unable to detect an Ethernet port or link aggregation on which the NAS server network interface was configured. Switch the interface to use another Ethernet port or link aggregation. If this does not help, restart the management software. If the problem persists, contact your service provider. (https://10.xxx.x.xx/help/webhelp/en_US/index.html?
uemcli /net/nas/server show -detail output showing the same error condition :
1:    ID                                          = nas_23
      Name                                        = nasservervdm4
      NetBIOS name                                = nasservervdm4
      SP                                          = spa
      Storage pool                                = pool_2
      Tenant                                      =
      Interface                                   = if_40
      NFS enabled                                 = yes
      NFSv3 enabled                               = yes
      NFSv4 enabled                               = no
      CIFS enabled                                = yes
      Workgroup                                   =
      Windows domain                              = removed.domain.com
      Multiprotocol sharing enabled               = yes
      Unix directory service                      = localThenNis
      Auto user mapping enabled                   = enabled
      Default Unix user                           = N/A
      Default Windows username                    =
      Extended Unix credentials enabled           = no
      Credentials cache retention                 = 15m
      Username translation                        = no
      Packet Reflect enabled                      = no
      Health state                                = Major failure (20)
      Health details                              = "The system is unable to detect an Ethernet port or link aggregation on which the NAS server network interface was configured. Switch the interface to use another Ethernet port or link aggregation. If this does not help, restart the management software. If the problem persists, contact your service provider. (https://10.x.xx.x.x/help/webhelp/en_US/index.html?#unity_t_manage_ns_interfaces_default_rtes.html)"
      Type                                        = 64
      Replication type                            = remote
      Synchronous replication type                = none
      Replication destination                     = yes
      Backup only                                 = yes
      Migration Destination                       = no
      Preferred production interfaces overridden  = Auto synchronized
      Preferred production IPv4 interface         = auto
      Preferred production IPv6 interface         = auto
      Preferred backup and DR test IPv4 interface = auto
      Preferred backup and DR test IPv6 interface = auto
      Source preferred production IPv4 interface  = auto
      Source preferred production IPv6 interface  = auto
      File space used                             = 69085582229504 (62.8T)
      Compression space saved                     = 0
      Compression percent                         = 0%
      Compression ratio                           = 1.0:1
      Data Reduction space saved                  = 0
      Data Reduction percent                      = 0%
      Data Reduction ratio                        = 1.0:1

 

Affected Products

Dell EMC Unity Family

Products

Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 500 , Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid ...
Article Properties
Article Number: 000060348
Article Type: Solution
Last Modified: 26 Sep 2025
Version:  4
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