Data Domain: Cannot delete logged in user due to stale entries in /var/run/utmp

Summary: Cannot delete logged in user.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Data Domain DDOS CLI (Command Line) and DDSM (System Manager GUI) cannot delete a user, if that same user is still logged in. 

In some scenarios of unknown cause, the user may be left in a logged in state, as such any attempts to remove the user will fail with an error as seen below:    
 
Welcome to Data Domain OS 
-----------------------------------------
## user del emctmp
**** Can not delete logged in user "emctmp".

This KB article aims at a specific scenario where the user cannot be deleted and is not shown in the active user list. 

Note: In most situations, the following article can be applied, KB article 534440: Data Domain : How to forcefully delete the user which is currently logged in DD (Only registered Dell Customers can access the content on the article link, via Dell.com/support)

Cause

The /var/run/utmp maintains a full accounting of the current status of the system, system boot time (used by uptime), recording user logins at which terminals, logouts, and system events. 

Due to unknown cause, a user may be left as logged in the utmp file, even if the user's session has already died or ended.

Resolution

STEPS for resolution based on the example of user "emctmp" 
  1. Log off of any other sessions with that user (Attempt to use KB article 534440: Data Domain : How to forcefully delete the user which is currently logged in DD (Only registered Dell Customers can access the content on the article link, via Dell.com/support)
    1. Confirm no other sessions exist with the same user. This may be a SSH which is still active, normally logging off solves it. 
    2. Attempt to remove the user again post logging off. 
  2. Reboot (if possible)
    1. If the first case does not apply, it means there is no session with the user, but the user is still seen as logged in as DDOS looks into /var/run/utmp to check the log in activity. 
    2. The /var/run/utmp is recreated at boot time and issue will be solved, user can then remove the user. 
  3. Contact support if you are unable to reboot to sort out the issue. The alternative is to manually remove the offending entries from /var/run/utmp. 
    1. This procedure can only be done by support via BASH mode. 

Affected Products

Data Domain

Products

Data Domain
Article Properties
Article Number: 000061310
Article Type: Solution
Last Modified: 20 Nov 2020
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.