NetWorker: LDAPS configuration: 'timestamp check failed' error message may occur with a valid certificate

Summary: NetWorker: LDAPS configuration: 'timestamp check failed' error message may occur with a valid certificate

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



 
  • NetWorker  

  •  Configuration of LDAPS frequently fails with timestamp check failed error message even when certificate is valid. 

  • Error executing command.Failure: 400 Bad Request. Server message: Failed to verify configuration ldaps1: An SSL handshake error occurred while attempting to connect to LDAPS server: timestamp check failed.

     

  • The certificate is valid until fut ure date.

Cause

  • Multiple entries for the ldap server in keystore, some of which may be expired.

Resolution

If the error message  Error executing command. Failure: 400 Bad Request. Server message: Failed to verify configuration LDAPS: An SSL handshake error occurred while attempting to connect to LDAPS server: timestamp check failed  is seen during authc_config, check the following from the NW server.

a. Ensure the date and time on NW server is in sync with the LDAP server
b. Verify if the certificate is a valid one by executing  openssl s_client -connect <LDAPS server:636> -CAfile <certificate> . If the command returns  Verify return code: 10 (certificate has expired) , it means the certificate has expired and cannot be used.  notAfter  field shows the validity of this certificate. 

Openssl tool is recommended to verify the certificate.

[root@ncdqd131 ~]# openssl s_client -connect <server>:636 -CAfile cert

Affected Products

NetWorker Series

Products

NetWorker Series
Article Properties
Article Number: 000061830
Article Type: Solution
Last Modified: 26 Mar 2025
Version:  4
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