Vipr Controller: Unable to discover Windows 2012 R2 SMI-S server
Summary: Port Conflict with WINRM and ECOM in Windows 2012 platform.
Symptoms
ECOM services do not start up on Windows 2012 R2 server.
Snippet Found from dbutils.list.StorageProvider (this snippet has been edited to show portions of log entry):
connectionStatus = INITIALIZING
interfaceType = smis
status = OpStatusMap (Status:error, Progress:null, Name:SCAN STORAGE PROVIDER, Message:"Scan failed for provider:
Message: Scan failed for provider: Scan job failed for SMISProvider: urnXXXXX because Not able to get CimConnection to SMISProvider <IP> on port 5989
portNumber = 5989
scanStatus = IN_PROGRESS (or scanStatus = ERROR)
Cause
This conflicts with the default ECOM ports required and can cause ECOM service not to start up .
Resolution
There are two ways to resolve the issue:
- Change the default WINRM 2.0 port using the command:
winrm set winrm/config/Listener?Address=*+Transport=HTTP @{Port="XXXX"}
where XXXX is the desired port number.
For example:
C:\Users\Administrator>winrm set
winrm/config/Listener?Address=*+Transport=HTTP @{Port="5980"} Listener Address = * Transport = HTTP Port = 5980 Hostname Enabled = true URLPrefix = wsman CertificateThumbprint ListeningOn = 10.xxx.xxx.xxx, 127.x.x.x, ::1,
fe80::5efe:10.xxx.xxx.xxx%13,
fe80::ffff:ffff:fffe%14, fe80::50f:e3ef:5529:4a16%12
- Change the default port configuration of ECOM. To do this, complete the following steps:
- Open the Port_Setting.xml file. On Windows C:\Program Files\EMC\ECIM\ECOM\conf\Port_settings.xml and on Linux /opt/emc/ECIM/ECOM/conf/Port_settings.xml
- Under the <ECOMSetting Name="Port2"> section change<port>5985</port> to <port>5500</port>
- Under the <ECOMSetting Name="Port 3"> section change <port>5986</port> to <port>5501</port>
- Save and close the file
Additional Information
These instruction come from EMC® Solutions Enabler, VSS Provider, and SMI-S Provider Version 8.0.3 Release Notes (page 78).
Link to release notes: https://support.emc.com/docu59412_Solutions-Enabler,-VSS-Provider-and-SMI-S-Provider-8.0.3-Release-Notes.pdf?language=en_US