Avamar : Sauvegarde Linux à partir du mauvais serveur
Summary: La restauration d’un client semble provenir du mauvais système et indique un hôte Linux incorrect dans le journal de sauvegarde Avamar.
Symptoms
Problèmes de restauration.
Lors d’une restauration, le log affiche un message similaire à celui-ci :
2017-08-15 10:59:23 avtar Info <40113>: Backup #92 created by avtar version 7.2.101-32 Backup from Linux host "/Linux/NYS/name-name3.domain.local" (name-name9.domain.local)
La sauvegarde est indiquée sous l’hôte Linux affiché, et non le système entre parenthèses. Cela indique que la restauration est effectuée sur le système entre parenthèses.
Lors de la navigation dans le client, un message d’avertissement s’affiche. Ce message indique que le client et l’ID client (CID) appropriés pointent vers un autre client et que le CID est rejeté.
Les ID client (CID) fournis correspondent au nom de client fourni.
Cause
Le problème peut être détecté lors de l’utilisation de l’interface utilisateur Avamar. Le chemin suivant est le même dans l’interface utilisateur que celui que le système suit pour obtenir ses informations. Politique>L’adresse de paging>du client>> permet de collecter l’adresse IP ou le nom d’hôte du client et le numéro de port auquel se connecter. Ce problème se produit car l’adresse dans l’adresse de pagination pointe vers un autre client.
Conditions particulières à l’origine du problème
Avamar s’appuie sur l’adresse de paging pour établir une connexion avec le client. Si cette adresse est incorrecte, cela peut conduire à la connexion du système au mauvais client.
- L’adresse de paging est utilisée pour déterminer l’adresse IP ou le nom d’hôte du client.
- Une adresse de paging incorrecte peut entraîner la connexion du système à un autre client.
Codes ou messages d’erreur pertinents
2017-08-15 10:59:23 avtar Info <40113>: Backup #92 created by avtar version 7.2.101-32 Backup from Linux host "/Linux/NYS/name-name3.domain.local" (name-name9.domain.local)
Resolution
Résolution des sauvegardes Avamar Linux
La solution la plus simple consiste à exécuter la commande avregister à partir du client avec l’adresse IP de pagination incorrecte. Ces étapes permettent de mettre à jour la section de paging avec les informations actuelles concernant le client.
# Run this command to update the paging section $ avregister
Après avoir exécuté la commande, vérifiez que le problème a bien été résolu en vérifiant les logs Avamar et en vous assurant que la sauvegarde est désormais effectuée à partir du serveur approprié.