Avamar with CloudBoost: After upgrading Java to JRE8u231, Avamar Administrator does not launch, showing message "Error: A JNI error has occurred. Please check your installation and try again"

Summary: After upgrading Java, receive JNI errors when trying to launch the GUI.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



The GUI does not work with the latest version of Java as it is incompatible. If Java is upgraded to the latest version, when launching the GUI, the following error is received:   

"Error: A JNI error has occurred. Please check your installation and try again"

Cause

The GUI and the latest Java version are incompatible.

Resolution

Option 1 (preferred)
Install the Java from the DTLT page on top of the newer Java that was just installed (this will be an older version of Java!)

Point the shortcut to the older Java following the steps below:   
  1. - Edit the properties of the shortcut and change the number in the "Target" section at the end after the tilde (~) to "1.0_1", click apply, and OK.
  2. Run the GUI shortcut
Note: Keep in mind some software scanners may remove the older Java and it may need to be redownloaded and reinstalled from DTLT to get it to work again. If that happens, reinstall the Java from DTLT. You should not have to follow all these steps again.

Option 2 (this works in some cases)
Go to the DTLT page and click the Administrator link and download the .jnlp file and run from that way.

Affected Products

Avamar

Products

Avamar, Avamar with CloudBoost
Article Properties
Article Number: 000062658
Article Type: Solution
Last Modified: 25 Sep 2024
Version:  3
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