ECS: GeoDrive experiences time out errors

Summary: Troubleshooting GeoDrive timeout errors

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Timeout errors identified when using GeoDrive.

Cause

The default HTTP timeout values may not be long enough for operations to complete successfully in all use cases.

Resolution

Background:
  • There are times when the default HTTP timeout values are not sufficient. Increasing the timeout may help in scenarios where there are many TIMEOUT errors but everything else is operating normally.
  • There are several registry values that govern the HTTP timeouts. These are explained further below.
  • Changing the timeout values does require using the regedit tool to modify the registry on older versions of GeoDrive. Whenever making any registry change, make sure the GeoDrive or CIFS-ECS service is not running.

Resolution:

WinHttpOption Timeouts:
 
The timeout parameters that most frequently require modification are:
  • WinHttpOptionReceiveResponseTimeout
  • WinHttpOptionReceiveTimeout
To change the timeout value:

For GeoDrive 2.0 or later:
 
Use these Command Prompt commands:
cloud_cli util UpdateReg WinHttpOptionReceiveResponseTimeout 360000

cloud_cli util UpdateReg WinHttpOptionReceiveTimeout 360000

cloud_cli util UpdateReg WinHttpOptionSendTimeout 360000

For earlier versions of GeoDrive:
  1. Stop the service:
net stop gdsvc
  1. Use regedit to select the desired key. The key information is below.
  2. The below values should appear:
WinHttpOptionReceiveResponseTimeout: 180000 (decimal)
WinHttpOptionReceiveTimeout: 180000 (decimal)
WinHttpOptionSendTimeout: 180000 (decimal)
  1. Set them to a higher value such as doubling the current values to 360000 (decimal). This sets them them to 6 minutes.
  2. Restart the service:
net start gdsvc

Folder Listing Timeout
If the TIMEOUT error is occurring from a folder listing request, in addition to increasing the timeout value, or instead of it, you can try decreasing the number of items requested for each bucket listing command. The default is 500. The maximum value is 1000. It can be set by changing the registry value: "S3BucketListingMax".
 
To Change the value: (GeoDrive 2.0 or greater)
cloud_cli util UpdateReg S3BucketListingMax 200
Timeout Variable Information:
 
Registry key:
 
GeoDrive 2.0 and greater:
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\GDSvc\Parameters


CIFS-ECS:
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CIFS-ECS\Parameters


GeoDrive 1.x:
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\GeoDrive\Parameters

 
Registry Values:

WinHttpOptionConnectRetries
  • Type: DWORD
  • Default: 5
  • Description: Sets or retrieves an unsigned long integer value that contains the number of times WinHTTP attempts to connect to a host. Microsoft Windows HTTP Services (WinHTTP) only attempts once per Internet Protocol (IP) address. For example: An attempt to connect to a multi-homed host that has 10 IP addresses and WINHTTP_OPTION_CONNECT_RETRIES set to 7 will result in WinHTTP only attempting to connect to the first seven IP address. Given the same set of 10 IP addresses and WINHTTP_OPTION_CONNECT_RETRIES set to 20 results in WinHTTP attempting each of the 10 only once. The request is cancelled if a connection attempt still fails after the specified number of attempts or if the connect timeout expired before then.
WinHttpOptionConnectTimeout
  • Type: DWORD
  • Default: 60000 (decimal) (This equals one minute)
  • Description: Sets or retrieves an unsigned long integer value that contains the time-out value in milliseconds. Setting this option to infinite (0xFFFFFFFF) will disable this timer. The request is cancelled if a TCP connection request takes longer than this time-out value. The default timeout is 60 seconds. The timeout limit is for individual connections in situations where there are multiple IP addresses for a single host (a multi-homed host).
WinHttpOptionReceiveResponseTimeout
  • Type: DWORD
  • Default: 180000 (decimal) (This equals 3 minutes)
  • Description: Sets or retrieves an unsigned long integer value that contains the timeout value in milliseconds. The value configures how long to wait to receive all response headers to a request. The request is cancelled if WinHTTP fails to receive all the headers within this timeout period. This timeout is checked only when data is received from the socket. This results in the client application not receiving notification until more data arrives from the server. If no data arrives from the server then the delay between the timeout expiration and notification of the client application could be as large as the timeout value set using the dwReceiveTimeout parameter of the WinHttpSetTimeouts function.
WinHttpOptionReceiveTimeout
  • Type: DWORD
  • Default: 180000 (decimal) (This equals 3 minutes)
  • Description: Sets or retrieves an unsigned long integer value that contains the time-out value in milliseconds. This value is used for timeouts relating to receiving a partial response to a request or read data. If the response takes longer than this time-out value then the request is canceled.
WinHttpOptionReceiveTimeout
  • Type: DWORD
  • Default: 180000 (decimal) (This equals 3 minutes)
  • Description: Sets or retrieves an unsigned long integer value that contains the time-out value in milliseconds. This value is used for timeouts relating to sending a request or write data. If sending the request takes longer than the timeout then the send operation is canceled.

Additional Information

This content is translated in other languages: 
https://downloads.dell.com/TranslatedPDF/AR-SA_531391.pdf
https://downloads.dell.com/TranslatedPDF/DE_531391.pdf
https://downloads.dell.com/TranslatedPDF/ES_531391.pdf
https://downloads.dell.com/TranslatedPDF/ES-XL_531391.pdf
https://downloads.dell.com/TranslatedPDF/FR_531391.pdf
https://downloads.dell.com/TranslatedPDF/IT_531391.pdf
https://downloads.dell.com/TranslatedPDF/JA_531391.pdf
https://downloads.dell.com/TranslatedPDF/KO_531391.pdf
https://downloads.dell.com/TranslatedPDF/NL_531391.pdf
https://downloads.dell.com/TranslatedPDF/PT_531391.pdf
https://downloads.dell.com/TranslatedPDF/PT-BR_531391.pdf
https://downloads.dell.com/TranslatedPDF/RU_531391.pdf
https://downloads.dell.com/TranslatedPDF/SV_531391.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_531391.pdf
https://downloads.dell.com/TranslatedPDF/ZH-TW_531391.pdf

Affected Products

Elastic Cloud Storage

Products

Elastic Cloud Storage
Article Properties
Article Number: 000062751
Article Type: Solution
Last Modified: 23 Sep 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.